Page MenuHomePhabricator

ULS Telugu Transliteration fails for typing Guninthas of character form జ్ఞ
Closed, ResolvedPublic

Description

Steps to Reproduce:

Enable 2010 Wikieditor toolbar in preferences.
Open any page to edit
Select Telugu Transliteration (లిప్యంతరీకరణ)  as input
Type SAstraj~nuDu

Actual Results:
శాస్త్రజ్ఞఉడు
Expected Results:
శాస్త్రజ్ఞుడు

Environment:
Ubuntu 18.04
Firefox 68.0.2(64bit)

Additional remarks:
All Guninthas (vowel suffixes i.e A aa i I ii ee u U uu oo R Ru ~l e E ai o O au ) of the complex consonant జ్ఞ also do not shape correctly.

This is not a problem when using inscript method. This is a major irritant, forcing users to resort to external primitive tools to get the word correct.

Ref: https://www.mediawiki.org/wiki/Help:Extension:UniversalLanguageSelector/Input_methods/te-transliteration

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 4 2019, 12:26 AM

Hi,

Thanks for creating the task.

@tuxnani once submitted a patch for it. It probably fixed some things, but it still didn't fix everything. I left comments on that old patch, but they weren't addressed.

Since it was very old, I rebased it, and the current version can be found at https://github.com/wikimedia/jquery.ime/pull/580 . It still needs fixes. I cannot make them myself because I don't understand the Telugu alphabet well enough. If someone who understands this alphabet well enough, like @tuxnani or anybody else, can work with me on this, I'll be happy to help complete it.

Arjunaraoc added a subscriber: santhosh.EditedJan 3 2020, 6:39 AM

@Amire80 , I have created pull request https://github.com/wikimedia/jquery.ime/pull/587 incorporating the changes by @tuxnani from https://github.com/wikimedia/jquery.ime/pull/585 and implementing the review feedback from @santhosh Please help with the next steps for deployment. Telugu transliteration tests passed successfully in QUnit 1.23.1; Mozilla/5.0 (X11; Linux x86_64; rv:71.0) Gecko/20100101 Firefox/71.0 environment.

Arjunaraoc closed this task as Resolved.Jan 14 2020, 3:44 PM
Arjunaraoc claimed this task.

Thanks, I found the change reflected on Telugu wikipedia