Page MenuHomePhabricator

run refreshLinks.php then updateArticleCount.php on banwiki
Closed, ResolvedPublic

Description

On the newly created banwiki (T234768), many pages containing "[[Kategori:…]]" links are not listed in the categories themselves. I assume this was caused by having its content imported before the wiki was properly configured to recognize "[[Kategori:…]]" as equivalent to "[[Category:…]]".

I don't believe this is a current configuration issue (hence not tagging this as a site request) because the problem can be fixed for individual pages by performing null edits on them.

But since there are over 1,800 pages on the wiki, it would be nice if this could get fixed all at once by running a maintenance script. I believe 'refreshLinks.php' is the script that is called for.

I also have significant doubt about the current article count shown on the wiki (168, but it looks to me like about half of the 1,160 main-namespace pages have wikilinks on them), so after running 'refreshLinks.php', please also run 'updateArticleCount.php'.

Related Objects

Event Timeline

Dcljr created this task.Oct 18 2019, 10:31 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 18 2019, 10:31 AM

Mentioned in SAL (#wikimedia-operations) [2019-10-18T11:56:14Z] <Reedy> mwscript refreshLinks.php banwiki on mwmaint1002 T235843

Reedy closed this task as Resolved.Oct 18 2019, 12:06 PM
Reedy claimed this task.
Reedy added a subscriber: Reedy.
reedy@mwmaint1002:~$ mwscript refreshLinks.php banwiki
Refreshing redirects table.
Starting from page_id 1 of 2667.
100
200
300
400
500
600
700
800
900
1000
1100
1200
1300
1400
1500
1600
1700
1800
1900
2000
2100
2200
2300
2400
2500
2600
Refreshing links tables.
Starting from page_id 1 of 2667.
100
200
300
400
500
600
700
800
900
1000
1100
1200
1300
1400
1500
1600
1700
1800
1900
2000
2100
2200
2300
2400
2500
2600
Deleting illegal entries from the links tables...
  Checking interval (-INF, INF)
    pagelinks: 0 deleted.
    imagelinks: 0 deleted.
    categorylinks: 0 deleted.
    templatelinks: 0 deleted.
    externallinks: 0 deleted.
    iwlinks: 0 deleted.
    langlinks: 0 deleted.
    redirect: 0 deleted.
    page_props: 0 deleted.
reedy@mwmaint1002:~$ mwscript updateArticleCount.php banwiki
Counting articles...found 727.
To update the site statistics table, run the script with the --update option.
reedy@mwmaint1002:~$ mwscript updateArticleCount.php banwiki --update
Counting articles...found 727.
Updating site statistics table... done.
reedy@mwmaint1002:~$
Dcljr added a comment.Oct 19 2019, 3:44 AM

Thanks. Looks like that did the trick (AFAICT).