Page MenuHomePhabricator

Curator reads a revision with source
Closed, InvalidPublic

Description

"As a curator, I want to get the wikitext source for a revision of a page, so I can understand the contents at that time."

Like the triad of reading endpoints for pages (embedded source, embedded HTML, separate metadata and HTML), this user story is for reviewing source for an older revision.

GET /revision/{id}

Return the revision of a page with source.

Request payload: none

Status code:

200 - OK
403 - Not authorized
404 - No such revision

Body: JSON, object with following fields:

  • id: revision ID
  • page: Object with these fields
    • id: ID of the page
    • title: current title of the page (might have been changed)
  • user: user who made the change, object with these fields
    • id: ID of the user or null for anonymous
    • name: name of the user or unique identifier for anonymous
  • comment: User comment ("edit summary") describing the change that generated this revision
  • timestamp: time the revision was made
  • size: size of the revision in "bogobytes" (as from DB, usually bytes)
  • delta: change from previous revision in "bogobytes" (as from DB, usually bytes)
  • minor: is this a minor edit? boolean
  • source: wikitext source for the revision

Event Timeline

eprodromou closed this task as Invalid.Nov 6 2019, 5:53 PM

Dupe of T235239.