Page MenuHomePhabricator

Trying to play QuizGame on a Miraheze Wiki, you can't get past the "Loading" display
Closed, ResolvedPublicBUG REPORT

Description

I'm working on the Miraheze wiki, Questio ( https://questio.miraheze.org/wiki/ ), but Extension: QuizGame doesn't work properly.

I can create quizzes correctly, but I can't play QuizGame. I can't get past the "Loading" display.

We had several users test, but none could play. This is probably an extension bug. Would you please fix this bug?

Event Timeline

Restricted Application added projects: Social-Tools, User-RhinosF1. · View Herald TranscriptFeb 9 2020, 6:13 AM
Restricted Application added subscribers: RhinosF1, Aklapper. · View Herald Transcript
Aklapper renamed this task from Extension:QuizGame can't played by no-one to Trying to play QuizGame on a Miraheze Wiki, you can't get past the "Loading" display.Feb 9 2020, 6:49 AM

@Schwarz19972007: What is a direct link to a page on that wiki which shows that "Loading" display?

Schwarz19972007 added a comment.EditedFeb 9 2020, 7:00 AM

Sorry, here is the link. Accessing each quiz directly has the same result. "Loading" is displayed as "読み込み中" in Japanese.

https://questio.miraheze.org/wiki/Special:QuizGameHome

When I accessed Questio from the link just above, the quiz was displayed correctly and I could play.

But, when I accessed from a link inside Questio, it still displays "読み込み中(Loading)",

Welcome to Wikimedia Phabricator, I’m going to get one of our collegues to look at this for you as soon as possible to confim where the issue is. I’m stalling this for now because we already have a downstream issue at https://phabricator.miraheze.org/T4947

RhinosF1 changed the task status from Open to Stalled.Feb 9 2020, 8:42 AM
RhinosF1 moved this task from Backlog to QuizGame on the Social-Tools board.
RhinosF1 moved this task from Backlog to Bugs on the QuizGame board.
RhinosF1 moved this task from Radar to Miraheze-Linked on the User-RhinosF1 board.

Hi, see your web browser's developer tools. If there is a problem or an error with JavaScript it should be printed in the 'console' of the developer tools.

In this case, it shows:

ReferenceError: jQuery is not defined 特別:QuizGameHome:240:4
    <anonymous> https://questio.miraheze.org/wiki/特別:QuizGameHome:240
    push https://questio.miraheze.org/w/load.php?lang=ja&modules=startup&only=scripts&raw=1&skin=vector:51
    <anonymous> https://questio.miraheze.org/wiki/特別:QuizGameHome:239

For more information please see:

ashley closed this task as Invalid.Feb 9 2020, 7:42 PM
ashley added a subscriber: ashley.

This was fixed by 46a13167e125e7dbaaef6004485612c425fe4e3b a while ago. Miraheze should update their version of QuizGame (and be mindful of T227345: Actor support for social tools while doing so).

@RhinosF1 @Aklapper Thanks for your activities!

Schwarz19972007 reopened this task as Open.Feb 16 2020, 2:38 AM

Is this really fixed?

I tryed to play QuizGame like before, so I went to Special:QuizGameHome on Questio. But I can't play QuizGame.

Then, when I accessed QuizGameHome from the link on this page, the quiz was temporarily displayed and I could answer, but no points were added.

I hope QuizGame can be played successfully.

RhinosF1 closed this task as Resolved.Feb 16 2020, 4:17 AM
RhinosF1 claimed this task.

The issue was fixed long ago. We need to uodate at Miraheze.

RhinosF1 moved this task from Miraheze-Linked to Done on the User-RhinosF1 board.Mar 3 2020, 10:38 PM