Page MenuHomePhabricator

Mary TTS STTS has a dependency to Mishkal running on startup
Closed, ResolvedPublic

Description

If unit tests that contact Mishkal is failing then Mary TTS will not start. Mary TTS should rather still start and perhaps if there is no connecting to Mishkal then it should stop serving Arabic features? Or at least just log that it's not working rather than crashing?

Related Objects

Event Timeline

kalle created this task.Mar 18 2020, 11:12 AM

@STTS Give a shout if the details are unclear

I can't reproduce this - here's what I get when starting MaryTTS without a running mishkal server:

marytts>./gradlew run
...
Vocalise url: http://localhost:8080/ajaxGet?action=Tashkeel2&text=+%D8%A7%D9%84%D9%8A%D9%88%D9%85+%D8%A7%D9%84%D8%A5%D8%AB%D9%86%D9%8A%D9%86+%D8%AE%D9%85%D8%B3%D8%A9+%D9%88+%D8%B9%D8%B4%D8%B1%D9%88%D9%86+%D9%8A%D9%86%D8%A7%D9%8A%D8%B1+%D8%A3%D9%84%D9%81%D9%8A%D9%86+%D9%88+%D8%B3%D8%AA%D8%A9+%D8%B9%D8%B4%D8%B1+.
Mishkal server not running - can't vocalise
started in 8.741 s on port 59125

Maybe I'm misunderstanding the question?

kalle added a comment.Mar 19 2020, 1:47 PM

Hmm, this is true for me too now. I wonder if this is something that occurred when I begun blubberizing and used most recent release rather than the git master?

Let's invalidate this patch. Sorry for taking your time!

kalle closed this task as Resolved.Mar 19 2020, 2:02 PM