Page MenuHomePhabricator

Flow failing with Error contacting the Parsoid/RESTBase server (HTTP 400)
Closed, DuplicatePublic

Description

Hi, for a few days, I've been having problems on talk pages using Flow (including my own of course) on frwikisource, wikidata, commons...

one of the error message was " Erreur d’accès au serveur Parsoid/RESTBase (HTTP 400) "

I'll try to add new kind of error message when they occur, but the problem happens randomly, while editing previous messages as well as when answering... had it twice today, but did not have the reflex to screen capture it at the time...

Event Timeline

Restricted Application added a project: Growth-Team. · View Herald TranscriptApr 11 2020, 11:27 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Hsarrazin added a comment.EditedApr 11 2020, 12:35 PM

message is "Une erreur s’est produite. Le message d’erreur reçu était : internal_api_error_Flow\Exception\NoParserException"

that one is triggered by wanting to edit a message.
had to re-load page to be able to do anything else...

Hsarrazin added a comment.EditedApr 11 2020, 4:39 PM

and again "[16ccf92c-443b-4708-86ca-568a3e8e00b9] Caught exception of type Flow\Exception\NoParserException"

that one was triggered by the "Publish" button

Framawiki renamed this task from Flow failing with red notification message... to Flow failing with Error contacting the Parsoid/RESTBase server (HTTP 400).Apr 12 2020, 8:26 PM

@Hsarrazin Hi, when does this message appear? When you're viewing an existing topic, creating a new one, or answering to a post? Can you copy link to post/flow board?

@ Growth-Team Can someone look in logstash for traceback corresponding to above error code, before it disappears? Thanks!

I've received an email via OTRS regarding this error on frwiki from an editor that was using VisualEditor while receiving this error message (&veaction=edit in url and not on a Flow page).

Aklapper removed a project: SRE.Apr 13 2020, 7:16 AM

@Framawiki: I don't see how this is related to Operations; feel free to elaborate.

@ Growth-Team Can someone look in logstash for traceback corresponding to above error code

Hmm, 16ccf92c-443b-4708-86ca-568a3e8e00b9 is maybe not an exception_id format; I am wondering what and how to search in Logstash.

@Hsarrazin Hi, when does this message appear? When you're viewing an existing topic, creating a new one, or answering to a post? Can you copy link to post/flow board?

in all cases... sometimes it's when creating a new post, sometimes editing, sometimes answering...

just now, when answering, I got this message on clicking on "Publish" to answer a question

on https://fr.wikisource.org/w/index.php?title=Sujet:Vkeyo236yj55g2kn&topic_showPostId=vkf92j5iivmusnwx&fromnotif=1#flow-post-vkf92j5iivmusnwx

This seems to be the same as T249705

Joe closed this task as Resolved.Apr 14 2020, 7:20 AM
Joe claimed this task.
Joe added a subscriber: Joe.

This seems to be the same as T249705

After further inspection, it is. Closing as a duplicate of that.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptApr 14 2020, 7:20 AM
Joe reopened this task as Open.Apr 14 2020, 7:21 AM

Ehm, phab UI fail.