Page MenuHomePhabricator

Upload Wizard uses template redirect {{PD-1923}}
Closed, ResolvedPublicBUG REPORT

Description

The Upload Wizard inserts the license template {{PD-1923}}, which is now a redirect to {{PD-US-expired}}. It should just insert {{PD-US-expired}} instead.

Steps to Reproduce:

  1. Upload a file in the Upload Wizard.
  2. On the Release Rights step, select "First published in the United States before 1925".
  3. Finish the file upload process.

Actual Results:
The resulting file uses the license {{PD-1923}}

Expected Results:
The resulting file should use the license {{PD-US-expired}}

Event Timeline

BMacZero created this task.May 2 2020, 10:16 PM
Restricted Application added subscribers: Liuxinyu970226, Aklapper. · View Herald TranscriptMay 2 2020, 10:16 PM

Change 593930 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/extensions/UploadWizard@master] Replace {{PD-1923}} with {{PD-US-expired}}

https://gerrit.wikimedia.org/r/593930

Seeing why this got changed before in https://phabricator.wikimedia.org/rEUWIec1e05c670df93167c58569dc5c093c9f0a6a0b8 this feels like some forth and back which might not be too helpful?

Both changes are moving forward, PD-US isn't the same thing as PD-US-expired. PD-US is a very broad template that isn't specific about the PD reason, which is probably the reason for the original change to the specific PD-1923. More recently, PD-1923 now actually refers to a year that moves up every year, so it was renamed to PD-US-expired as the old name is no longer accurate.

The PD-US documentation recommends using PD-US-expired instead: https://commons.wikimedia.org/wiki/Template:PD-US
Discussion to rename PD-1923 to PD-US-expired: https://commons.wikimedia.org/wiki/Commons_talk:Public_Domain_Day#Propose_rename_to_not_mention_a_year_-_template_problem

Any life here? Do I need to collect consensus or anything like that?

Someone needs to +2 the patch in https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/UploadWizard/+/593930/ According to https://www.mediawiki.org/wiki/Developers/Maintainers , the Structured Data team is the code steward of UploadWizard. Explicitly adding them here, as it seems this patch was missed so far.

Change 593930 merged by jenkins-bot:
[mediawiki/extensions/UploadWizard@master] Replace {{PD-1923}} with {{PD-US-expired}}

https://gerrit.wikimedia.org/r/593930

Jdforrester-WMF closed this task as Resolved.May 22 2020, 9:46 PM
Jdforrester-WMF assigned this task to Reedy.