Page MenuHomePhabricator

Moving "patrol" right from autoconfirmed to autopatrolled users on it.wiki
Closed, ResolvedPublic

Description

Hi,
As discussed here, can you remove the "patrol" right ("mark others' edits as patrolled ") from autoconfirmed users and add it to autopatrolled users on it.wikipedia?
Thanks
Best regards

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSun, Aug 30, 8:41 PM

Change 623191 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] itwiki: Assign patrol right to autopatrolled instead of autoconfirmed

https://gerrit.wikimedia.org/r/623191

Urbanecm claimed this task.Sun, Aug 30, 9:44 PM
Urbanecm triaged this task as Medium priority.
Restricted Application added a project: User-Urbanecm. · View Herald TranscriptSun, Aug 30, 9:44 PM
Urbanecm moved this task from Backlog to To deploy on the User-Urbanecm board.Sun, Aug 30, 9:46 PM
Urbanecm moved this task from Backlog to To deploy on the Wikimedia-Site-requests board.
Superpes15 added a comment.EditedSun, Aug 30, 10:59 PM

@Urbanecm Please, also rollbacker group needs the "patrol" right, because a rollbacker must be an autopatrolled user but he's removed from the autopatrolled group when he gets the rollback flag. Lastly, the patrol right should also be removed from "confirmed" users (who have the same rights as autoconfirmed users), thanks.

@Urbanecm Please, also rollbacker group needs the "patrol" right, because a rollbacker must be an autopatrolled user but he's removed from the autopatrolled group when he gets the rollback flag. Lastly, the patrol right should also be removed from "confirmed" users (who have the same rights as autoconfirmed users), thanks.

Yes, confirmed user group is automatically mirrored to match autoconfirmed, so it would work for that group too. I'll do the rollback change.

Change 623191 merged by jenkins-bot:
[operations/mediawiki-config@master] itwiki: Assign patrol right to autopatrolled instead of autoconfirmed

https://gerrit.wikimedia.org/r/623191

Mentioned in SAL (#wikimedia-operations) [2020-08-31T18:27:04Z] <urbanecm@deploy1001> Synchronized wmf-config/InitialiseSettings.php: bb28e9da8057a4c92cd4d564ffd000f320338cda: itwiki: Assign patrol right to autopatrolled instead of autoconfirmed (T261587) (duration: 00m 53s)

Urbanecm closed this task as Resolved.Mon, Aug 31, 6:33 PM

Should be all done!