Page MenuHomePhabricator

Javascript features broken on Special:NotifyTranslators
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. Go to https://meta.wikimedia.org/wiki/Special:NotifyTranslators

Not working:

  • language selector with suggestions
  • date selector
  • preview

Caused by refactoring in Translate. Got alerted about this in https://gerrit.wikimedia.org/r/c/mediawiki/extensions/TranslationNotifications/+/624986

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 7 2020, 7:41 AM

Possible alternatives:

  • Rescue the old code from Translate and copy to TranslationNotifications (probably easiest)
  • Use the new code from Translate (creates OOUI vs. non-OOUI mismatch in looks; I think it isn't a big deal)
  • Convert the whole form to OOUI (most amount of work, but would bring some consistency with rest of MediaWiki)

Change 625637 had a related patch set uploaded (by Abijeet Patro; owner: Abijeet Patro):
[mediawiki/extensions/TranslationNotifications@master] Fix broken language selector on the Special:NotifyTranslator page

https://gerrit.wikimedia.org/r/625637

abi_ added a subscriber: abi_.

For now took this approach: Rescue the old code from Translate and copy to TranslationNotifications (probably easiest)

Did not see a straight forward way of using just the new LanguagesMultiselectWidget for this control, since HtmlFormFactory expects $displayFormat to be either a normal vform or ooui.

abi_ triaged this task as High priority.Sep 7 2020, 1:52 PM

Change 625637 merged by jenkins-bot:
[mediawiki/extensions/TranslationNotifications@master] Fix broken language selector on the Special:NotifyTranslator page

https://gerrit.wikimedia.org/r/625637

Nikerabbit assigned this task to abi_.Sep 8 2020, 8:04 AM
abi_ closed this task as Resolved.Sep 9 2020, 5:14 AM

Tested this on Mediawiki.org. No longer facing the reported issues.