Page MenuHomePhabricator

Broken package state on cp4032
Closed, ResolvedPublic

Description

The host apparently has some test packages installed, but they cause a broken package state:

The following packages have unmet dependencies:
libvmod-re2 : Depends: libvarnishapi2 (>= 6.0.6-1wm1) but 6.0.4-1wm1 is installed
varnish-modules : Depends: libvarnishapi2 (>= 6.0.6-1wm1) but 6.0.4-1wm1 is installed
varnishkafka : Depends: varnish (>= 6.0.6-1wm1) but 6.0.4-1wm1 is installed

Depends: libvarnishapi2 (>= 6.0.6-1wm1) but 6.0.4-1wm1 is installed

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 19 2020, 3:43 PM
MoritzMuehlenhoff triaged this task as Medium priority.Nov 19 2020, 3:43 PM

Change 642104 had a related patch set uploaded (by Vgutierrez; owner: Vgutierrez):
[operations/puppet@production] Revert "Purge remove apt-listchanges"

https://gerrit.wikimedia.org/r/642104

Change 642104 merged by Vgutierrez:
[operations/puppet@production] Revert "Purge remove apt-listchanges"

https://gerrit.wikimedia.org/r/642104

Mentioned in SAL (#wikimedia-operations) [2020-11-24T09:13:19Z] <ema> cp4032: switch back to varnish 6.0.6-1wm2 after T264398 experiment, fix T268243

Change 643150 had a related patch set uploaded (by Ema; owner: Ema):
[operations/puppet@production] Revert "Revert "Purge remove apt-listchanges""

https://gerrit.wikimedia.org/r/643150

Change 643150 merged by Ema:
[operations/puppet@production] Revert "Revert "Purge remove apt-listchanges""

https://gerrit.wikimedia.org/r/643150

ema closed this task as Resolved.Nov 24 2020, 3:18 PM

Mentioned in SAL (#wikimedia-operations) [2020-11-24T09:13:19Z] <ema> cp4032: switch back to varnish 6.0.6-1wm2 after T264398 experiment, fix T268243

This fixed the issue. Closing!