Page MenuHomePhabricator

Some Math characters do not appear correctly in Chromium based browsers unless you zoom in once or twice
Closed, InvalidPublicBUG REPORT

Description

List of steps to reproduce (step by step, including full links if applicable):
Visit Sigmaster's conjecture#Elementary examples, Nilpotent matrix#Example 2, or De Moivre's formula#Formulae for cosine and sine individually on Wikipedia in either Chrome or Edge (or any other Chromium-based browser)

What happens?: Some digits (such as the zero in the lower-right corner of matrix B at Nilpotent matrix#Example 2 and one of the digits equal to 4 in the number 61218182743304701891431482520 at Sigmaster's conjecture#Elementary examples) are not displayed correctly. If you zoom in at Sigmaster's conjecture#Elementary examples, the following digit 3 and the second-to-last digit 2 (between 8 and 5) are not displayed correctly. If you zoom in once more, then all digits would appear correctly.

At De Moivre's formula#Formulae for cosine and sine individually, some characters are also not displayed correctly, as reported by NadVolum at the Wikipedia link at the bottom.

What should have happened instead?: All characters appear correctly.

Software version (if not a Wikimedia wiki), browser information, screenshots, other information, etc:

T292350 image 1.PNG (95×164 px, 2 KB)
at 100% zoom level

T292350 image 2.PNG (22×277 px, 2 KB)
at 100% zoom level

T292350 image 3.PNG (25×306 px, 2 KB)
at 110% zoom level

T292350 image 4.PNG (25×346 px, 3 KB)
at 125% zoom level

Using Microsoft Edge on Windows 10 (version 94.0.992.38 if that matters)

https://en.wikipedia.org/wiki/Wikipedia_talk:WikiProject_Mathematics#Messed_up_math_display

Event Timeline

Aklapper changed the task status from Open to Stalled.Oct 4 2021, 7:15 AM

Please attach a screenshot, provide exact browser version information, and provide your exact zoom level. See the last bullet point in the form above - thanks!

Cannot reproduce in Chromium 94.0.4606.61 but we still have no idea which software versions you use. Please see my previous comment.

Screenshot from 2021-10-04 16-14-53.png (231×1 px, 30 KB)

I also expect this to be a rendering issue to be fixed in some web browser code instead and not a server-side issue in Math code.

@Aklapper another important information is if "experimental web platform features" is enabled or not? That determines if Chrome uses the latest MathML features or SVG images.

GeoffreyT2000 renamed this task from Some numbers do not appear correctly in Chrome or Edge unless you zoom in once or twice to Some characters do not appear correctly in Chrome or Edge unless you zoom in once or twice.Oct 5 2021, 1:55 PM
GeoffreyT2000 updated the task description. (Show Details)

I have added another example reported by NadVolum.

@GeoffreyT2000: Please read previous comments here and provide sufficient information. Thanks.

More information on the de Moivre example

My Google Chrome version is
Version 94.0.4606.71 (Official Build) (64-bit)

And I got a screen capture

Image2.png (113×408 px, 7 KB)
of the formulae as I see them

Thanks

If I click on the SVG image

https://wikimedia.org/api/rest_v1/media/math/render/svg/3ea817d332c1c183f8dccce58209afacef08d5aa

in Chrome I see the problem - but a bit changed! Other bits are corrupted instead. If I press + to enlarge it it looks okay but 0 to go to standard size brings back the problems. In Inkscape it is fine if I press - a few times to make it look much smaller than the Chrome image.

That's really weird, I don't know if you've noticed, but the corrupted characters look like they are flipped over a back diagonal!

Try parameter --use-angle=d3d9 if you are on Windows. It helps me.

I think there is nothing that can be done from the Math extension point of view. The problem should be probably fixed in the chromium project.

Aklapper renamed this task from Some characters do not appear correctly in Chrome or Edge unless you zoom in once or twice to Some Math characters do not appear correctly in Chromium based browsers unless you zoom in once or twice.Oct 6 2021, 8:45 AM
Aklapper closed this task as Invalid.

Thanks everyone for testing. T292350#7404000 implies that this is a Chromium issue. Please report this to https://bugs.chromium.org/p/chromium/issues/ and copy/paste the contents of the about:gpu page at the end of that report, and then paste the link to that new report here in Wikimedia Phabricator. Thanks a lot!