Page MenuHomePhabricator

Rendering of SVG text too large (font sans)
Closed, ResolvedPublic

Description

Author: M8R-udfkkf

Description:
How it properly renders in FF 14 & IE 9

The text in the following svg file renders too large.

https://commons.wikimedia.org/wiki/File:Pictograph_aligned_and_similar_size.svg

The svg file properly renders in FF 14 & IE9.

This may be related to:
T15486, T15494

The element for the rendering of "Banana" is:

<text
   xml:space="preserve"
   style="font-size:40px;font-style:normal;font-weight:normal;line-height:125%;letter-spacing:0px;word-spacing:0px;fill:#000000;fill-opacity:1;stroke:none;font-family:Sans"
   x="10"
   y="112.36218"
   id="text2995"
   sodipodi:linespacing="125%"><tspan
     sodipodi:role="line"
     id="tspan2997"
     x="10"
     y="112.36218">Banana</tspan></text>

Version: unspecified
Severity: normal
See Also:
T25643: Allow alternative declaration of SVG fonts (font-family="'FontName-Bold'" in addition to: font-family="Font name" font-weight="bold")

Attached:

Details

Reference
bz38589

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 12:55 AM
bzimport set Reference to bz38589.
bzimport added a subscriber: Unknown Object (MLST).

M8R-udfkkf wrote:

How its not properly rendered on the wiki.

attachment url.txt ignored as obsolete

M8R-udfkkf wrote:

How its not properly rendered on the wiki.

Attached:

This is not really a bug more like a Inkscape bug. There is only a (false generic) font-family: "Sans" which FF and IE9 and Chrome don't interpret (only Pango) but libRSVG does (as compatibly support). There are also several text bugs for Inkscape and several only for sans-serif.

So I suggest to close this report.

Aklapper updated the task description. (Show Details)Mar 8 2016, 7:37 PM
Aklapper set Security to None.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 8 2016, 7:37 PM
Aklapper closed this task as Resolved.Mar 8 2016, 7:39 PM
Aklapper claimed this task.

Cannot reproduce the output shown in T40589#444977 on https://commons.wikimedia.org/wiki/File:Pictograph_aligned_and_similar_size.svg with any of the given thumbnail links.

Closing as resolved. (See also last comment.)