Page MenuHomePhabricator

"Visited" status does not update until watchlist page is refreshed
Closed, ResolvedPublic

Description

Page titles listed in a watchlist are shown in bold if the page has been edited since it was last visited. (This style is applied with the "mw-changeslist-line-watched" class.) However, upon clicking a link to the page, the "visited" status does not immediately change, leaving the title incorrectly still bolded. The status is not updated until the page is reloaded.

I suggest adding some javascript to the watchlist page making it so that when the link is clicked, the "mw-changeslist-line-watched" class is immediately replaced with "mw-changeslist-line-not-watched".


Version: 1.19
Severity: normal

Details

Reference
bz38908

Related Objects

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 12:48 AM
bzimport added a project: MediaWiki-Watchlist.
bzimport set Reference to bz38908.
bzimport added a subscriber: Unknown Object (MLST).
Yair_rand created this task.Aug 1 2012, 7:22 AM
indielives added a subscriber: indielives.EditedJan 6 2015, 1:16 AM

This task is still to be solved, restrictions haven't been added yet. This was tested with Mozilla Firefox version 34.0.5 on Microsoft Windows 8.1.
How to recheck:
Login to en.wikipedia.org or any other Wiki based on the MediaWiki project.
Add an article to your watchlist
Edit the article with an other accout
Go to your watchlist again; when you access its source code, you can see that the class "mw-changeslist-line-watched" for your article is set. Open the article in a new tab
If you look again at your watchlist and its sourcecode, the class of your article is still "mw-changeslist-line-watched".
This shows that it was not actualized.

I am sorry if I don't understand the problem fully, but why do we need to make an ajax request to get the new state. If the issue is just that the visited status isn't updated then can't we just remove the class when the link is clicked?

https://gerrit.wikimedia.org/r/#/c/184327/

Change 184327 had a related patch set uploaded (by Prtksxna):
ChangeList: Unbold title when its clicked

https://gerrit.wikimedia.org/r/184327

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 1 2015, 3:05 PM
matmarex closed this task as Resolved.Dec 16 2015, 9:51 AM
matmarex claimed this task.

Change 184327 merged by jenkins-bot:
SpecialWatchlist: Unbold title when it's clicked

https://gerrit.wikimedia.org/r/184327