VisualEditor: Deletion of slugs causes significant confusion (and shouldn't be possible?)
Closed, ResolvedPublic

Description

Example Page: http://en.wikipedia.org/wiki/Ansaldo_Poggi

  1. Go to the top, click into the empty line above the ineditable image (the normally right floating image). This empty line should not exist. It can however, be deleted (press "delete" on the keyboard) which causes the start text to jump in front of the "Modern Bolognese Violin-Making Table" image.
  1. Click somewhere inside "References". Move the cursor with the keyboard to the position after the "s". Press "delete" on the keyboard. The line starting with "Tito Gotti" will be merged with the heading (ignoring the uneditable "references" tag and "cite" template).
  1. Similar to the above: Click somewhere inside "References". Move the cursor with the keyboard to the position after the "s". Move one more right into the (errorneously existing) empty line between the heading and the uneditable references tag. Press "delete" on the keyboard. The line starting with "Tito Gotti" will jump above the uneditable "references" tag and "cite" template.
  1. Do the same as above, i.e. go to the empty line after the References-Heading. However, this time click with the mouse into the line. Press "delete" on the keyboard. This time the behavior is different, nothing is deleted and the cursor jumps to the start of the article. This in itself seems again to be an error in the ordering of page objects. Now try to repeat this with different browser windows screen or zoom sizes, so that the originally, the start of the article is not visible before clicking delete. It can be seen that the focus is not updated, the cursor is outside of the visible area. Press "delete" again and with seeing it, parts of the text can be deleted.
  1. Do the same as above, click on line below reference with the mouse, delete once, cursor jumps to top. Do not delete again, but put the cursor again into the line below the reference heading with the mouse. This time the ineditable <references> tag is deleted.

Version: unspecified
Severity: normal

bzimport set Reference to bz43026.
G.Hagedorn created this task.Via LegacyDec 12 2012, 5:49 PM
rmoen added a comment.Via ConduitDec 12 2012, 7:43 PM

Thank you for the bug report. Though I am unable to reproduce the first step in Firefox or Chrome. To help with debugging, would you please include your browser information?

G.Hagedorn added a comment.Via ConduitDec 12 2012, 8:12 PM

Gladly: Windows 7, continuous updates, Google Chrome, Version 23.0.1271.95 m

TrevorParscal added a comment.Via ConduitFeb 11 2013, 6:59 PM

Created attachment 11767
Mockup of VisualEditor in various modes

Just wanted to note that slugs were an experimental solution to the problem of "how do you allow users to insert content between non-text things?

We have had a lot of ideas, but so far the direction we intend to go is to remove them entirely from the existing "layout" mode and provide an "outline" mode to the editor which includes them. There could also be a "source" mode where we could integrate the markup editing experience directly into VisualEditor.

Attached:

G.Hagedorn added a comment.Via ConduitFeb 11 2013, 9:06 PM

Would having an object inspector on the non-editable non-text things that provides options to "insert text before"/"insert text after" be a solution to the problem?

Jdforrester-WMF moved this task to Backlog on the VisualEditor workboard.Via WebNov 24 2014, 1:22 AM
Jdforrester-WMF closed this task as "Resolved".Via WebJan 9 2015, 10:54 PM
Jdforrester-WMF claimed this task.

These are all moot since the redesign of slugs over a year ago.

Jdforrester-WMF set Security to None.

Add Comment

Column Prototype
This is a very early prototype of a persistent column. It is not expected to work yet, and leaving it open will activate other new features which will break things. Press "\" (backslash) on your keyboard to close it now.