VisualEditor: Relabel buttons in "cancel editing" confirmation dialog
Closed, ResolvedPublic

Description

Author: ignatzmice.wiki

Description:
The button to cancel edits and return to read mode is labeled "cancel"; clicking it brings up a dialog box with buttons "OK" and "cancel". Clicking *that* "cancel" cancels the cancel and returns to editing mode—not blatantly wrong, but confusing. Perhaps the first button should be renamed "discard edits" or similar?

Original thread: https://en.wikipedia.org/w/index.php?title=Wikipedia:VisualEditor/Feedback&oldid=564868353#Ambiguity_in_.22Are_you_sure_you_want_to_cancel.22_dialog.3F See also bug 47676, closed as WONTFIX.


Version: unspecified
Severity: normal

bzimport set Reference to bz51655.
bzimport created this task.Via LegacyJul 19 2013, 3:14 AM
TTO added a comment.Via ConduitJul 19 2013, 5:43 AM

The confirmation dialog should have more descriptive buttons, such as [Discard edits] [Continue editing], or [Leave editing mode] [Return to editing], etc.

For this to happen, it needs to become a jQuery dialog.

In fact, VE shouldn't use native confirm() dialogs; the implementation in most browsers is crappy.

Jdforrester-WMF added a comment.Via ConduitJul 19 2013, 9:05 PM

Merging with bug 50955.

  • This bug has been marked as a duplicate of bug 50955 ***

Add Comment

Column Prototype
This is a very early prototype of a persistent column. It is not expected to work yet, and leaving it open will activate other new features which will break things. Press "\" (backslash) on your keyboard to close it now.