Page MenuHomePhabricator

Vagrant dependent on MediaWiki 1.21+
Closed, DeclinedPublic

Description

At some point Vagrant was switched over from using Memcached to use Redis. Unfortunately, RedisBagOStuff was only implemented recently, thus making it difficult to switch MediaWiki versions.

It'd be nice if memcached were still installed on the instance and (optionally) if the LocalSettings.php could detect if Redis is supported before setting it as the cache.


Version: unspecified
Severity: normal

Details

Reference
bz56048

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 2:27 AM
bzimport added a project: MediaWiki-Vagrant.
bzimport set Reference to bz56048.
bzimport added a subscriber: Unknown Object (MLST).
ori added a comment.Apr 19 2014, 8:33 PM

I'm not especially motivated to fix this myself, but I'd be happy to review a patch.

(In reply to Tyler Romeo from comment #0)

At some point Vagrant was switched over from using Memcached to use Redis.

The specific change is Idbaf405a3d1d3a2b0ed27b0cbd2048c8e893b4c8.

long since merged. Closing bug.

@mark, what was merged? Could you link the patch?

I don't know what I thought addressed this. Re-opening.

bd808 added a comment.Nov 17 2014, 9:35 PM

Bulk unassigning bugs from Ori.

bd808 triaged this task as Lowest priority.Dec 30 2014, 1:38 AM
bd808 added a subscriber: bd808.
bd808 closed this task as Declined.Jul 9 2016, 9:13 PM

MediaWiki 1.23 is now he oldest supported version. Making MediaWiki-Vagrant compatible with unsupported legacy versions of MediaWiki is not a priority or even really desirable.