Page MenuHomePhabricator

Special:Export DB connection was already closed. (Wikipedia export XML contains HTML)
Closed, ResolvedPublic

Description

2014-05-09 20:00:46 mw1179 jawiki: [d88a2ebd] /w/index.php Exception from line 1093 of /usr/local/apache/common-local/php-1.24wmf3/includes/db/Database.php: DB connection was already closed.
#0 /usr/local/apache/common-local/php-1.24wmf3/includes/db/Database.php(3492): DatabaseBase->query('COMMIT', 'DatabaseBase::c...')
#1 /usr/local/apache/common-local/php-1.24wmf3/includes/db/Database.php(3477): DatabaseBase->doCommit('DatabaseBase::c...')
#2 /usr/local/apache/common-local/php-1.24wmf3/includes/db/Database.php(937): DatabaseBase->commit('DatabaseBase::c...', 'flush')
#3 /usr/local/apache/common-local/php-1.24wmf3/includes/db/LoadBalancer.php(870): DatabaseBase->close()
#4 /usr/local/apache/common-local/php-1.24wmf3/includes/specials/SpecialExport.php(395): LoadBalancer->closeAll()
#5 /usr/local/apache/common-local/php-1.24wmf3/includes/specials/SpecialExport.php(179): SpecialExport->doExport('?????????:Cho-j...', Array, false, false)
#6 /usr/local/apache/common-local/php-1.24wmf3/includes/specialpage/SpecialPage.php(379): SpecialExport->execute(NULL)
#7 /usr/local/apache/common-local/php-1.24wmf3/includes/specialpage/SpecialPageFactory.php(503): SpecialPage->run(NULL)
#8 /usr/local/apache/common-local/php-1.24wmf3/includes/Wiki.php(285): SpecialPageFactory::executePath(Object(Title), Object(RequestContext))
#9 /usr/local/apache/common-local/php-1.24wmf3/includes/Wiki.php(596): MediaWiki->performRequest()
#10 /usr/local/apache/common-local/php-1.24wmf3/includes/Wiki.php(448): MediaWiki->main()
#11 /usr/local/apache/common-local/php-1.24wmf3/index.php(46): MediaWiki->run()
#12 /usr/local/apache/common-local/w/index.php(3): require('/usr/local/apac...')
#13 {main}


Version: 1.24rc
Severity: normal

Details

Reference
bz65100

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 3:13 AM
bzimport set Reference to bz65100.
Reedy created this task.May 9 2014, 8:02 PM

Not sure what the impact of this is (when this happens and how often) and what the priority should be - Reedy?

mwalker wrote:

This is happening about once a second right now.

Reedy added a comment.May 16 2014, 2:08 PM
  • Bug 65212 has been marked as a duplicate of this bug. ***

per Bug 65212: higher priority. A error message with this exception is at the end of the export-file and this may also cause problems at ImportUpload if not removed.

see also other userreport at https://de.wikipedia.org/w/index.php?title=Wikipedia:Technik/Werkstatt&oldid=130460889#Internal_error_beim_Export_von_Artikeln

Change 133760 had a related patch set uploaded by Aaron Schulz:
Minor fix to DatabaseBase::close() logic

https://gerrit.wikimedia.org/r/133760

Change 133853 had a related patch set uploaded by Aaron Schulz:
Minor fix to DatabaseBase::close() logic

https://gerrit.wikimedia.org/r/133853

Change 133854 had a related patch set uploaded by Aaron Schulz:
Minor fix to DatabaseBase::close() logic

https://gerrit.wikimedia.org/r/133854

Change 133760 merged by jenkins-bot:
Minor fix to DatabaseBase::close() logic

https://gerrit.wikimedia.org/r/133760

Change 133853 merged by jenkins-bot:
Minor fix to DatabaseBase::close() logic

https://gerrit.wikimedia.org/r/133853

Change 133854 merged by jenkins-bot:
Minor fix to DatabaseBase::close() logic

https://gerrit.wikimedia.org/r/133854

Aaron: Thanks for the patch!

Fix got merged (closing as RESOLVED FIXED as it's fixed in the codebase).