Page MenuHomePhabricator

[Regression] Flow: Watching or unwatching item no longer works (Uncaught exception from Handlebars)
Closed, ResolvedPublic

Description

https://www.mediawiki.org/wiki/Talk:Search is on my watchlist.

  1. Click Green star to unwatch.

Expected:

  • busy cursor
  • ajax request
  • icon changes to indicate state is now unwatched
  • confirmation message

Actual result

  • busy cursor
  • (nothing)

Uncaught Error: if doesn't match unless - 2:1 VM143:22
Handlebars.AST.BlockNode VM143:22
anonymous VM143:27
parse VM143:37
parse VM143:46
compileInput VM143:54
ret VM143:54
FlowHandlebars.processTemplate VM143:71
FlowHandlebars.processTemplateGetFragment VM143:72
FlowBoardComponent.UI.events.apiHandlers.watchItem


Version: unspecified
Severity: critical

Details

Reference
bz70137

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 3:34 AM
bzimport set Reference to bz70137.
bzimport added a subscriber: Unknown Object (MLST).
Krinkle created this task.Aug 28 2014, 7:49 PM

Looks like watching is broken as well, not just unwatching.

In Firefox I get no feedback but watch succeeds.
If I add ?debug=1 I see "Error: if doesn't match unless - 2:1" in the browser console

gerritadmin wrote:

Change 156983 had a related patch set uploaded by Bsitu:
template if / unless mismatch

https://gerrit.wikimedia.org/r/156983

gerritadmin wrote:

Change 156983 merged by jenkins-bot:
Fix client-side watch error

https://gerrit.wikimedia.org/r/156983

gerritadmin wrote:

Change 156992 had a related patch set uploaded by Spage:
Fix client-side watch error

https://gerrit.wikimedia.org/r/156992

gerritadmin wrote:

Change 156992 merged by jenkins-bot:
Fix client-side watch error

https://gerrit.wikimedia.org/r/156992

gerritadmin wrote:

Change 156994 had a related patch set uploaded by Spage:
Update Flow bug 70137 backport

https://gerrit.wikimedia.org/r/156994

gerritadmin wrote:

Change 156994 merged by MaxSem:
Update Flow bug 70137 backport

https://gerrit.wikimedia.org/r/156994

Fixed, backported to 1.24wmf19 and deployed.

Quiddity removed a subscriber: Maryana.Dec 19 2014, 1:36 AM
Sunpriat reopened this task as Open.Mar 29 2015, 7:33 PM
Sunpriat set Security to None.
This comment was removed by Sunpriat.
Sunpriat closed this task as Resolved.Mar 30 2015, 6:56 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptMar 30 2015, 6:56 PM