Page MenuHomePhabricator

Formatting of media player broken inside Listen template
Closed, ResolvedPublic

Description

screenshot of listen template as displayed on en.wiki

Compare media player in...
https://en.wikipedia.org/wiki/Nocturne_in_C-sharp_minor,_Op._posth._%28Chopin%29
...to media player here...
https://commons.wikimedia.org/w/index.php?title=File%3ANocturne_in_D-flat_Major%2C_Op._27%2C_No._2_xo.ogg

Or see screenshot.


Attached:

Details

Reference
bz71601

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 3:59 AM
bzimport added a project: MediaWiki-General.
bzimport set Reference to bz71601.
bzimport added a subscriber: Unknown Object (MLST).
kaldari created this task.Oct 3 2014, 8:20 AM

Looks like this is caused by a bug in jQuery UI that was fixed a while back:
http://bugs.jqueryui.com/ticket/8442

Since we haven't updated jQuery UI in a couple years, I'm guessing there's not much interest in doing so. I'll just backport the bugfix to our current version for now.

Change 164521 had a related patch set uploaded by Kaldari:
Backport of jQuery UI bugfix for ui-helper-clearfix class

https://gerrit.wikimedia.org/r/164521

Is bug 69687 a duplicate of this?

Change 164521 merged by jenkins-bot:
jquery.ui: Collapse border in ui-helper-clearfix

https://gerrit.wikimedia.org/r/164521

  • Bug 48858 has been marked as a duplicate of this bug. ***
  • Bug 69687 has been marked as a duplicate of this bug. ***
kaldari reopened this task as Open.Nov 30 2014, 11:39 PM
kaldari set Security to None.

Change 176620 had a related patch set uploaded (by Kaldari):
Synchronizing Vector jQuery UI styling with core to fix regression

https://gerrit.wikimedia.org/r/176620

Patch-For-Review

Change 176620 merged by jenkins-bot:
Synchronizing Vector jQuery UI styling with core to fix regression

https://gerrit.wikimedia.org/r/176620

brion added a subscriber: brion.Jan 23 2015, 8:01 PM
matej_suchanek updated the task description. (Show Details)
matej_suchanek removed a subscriber: wikibugs-l-list.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 2 2016, 3:36 PM
Ethanreese closed this task as Resolved.Dec 30 2016, 12:36 AM
Ethanreese claimed this task.
Ethanreese removed a project: TestMe.
Ethanreese added a subscriber: Ethanreese.

Going to the link on wikipedia in the chrome browser on macOS Sierra showed that the alignment error was fixed, and now it is aligned correctly, see the screenshot.