Page MenuHomePhabricator

integration-config-tox-py27 fails with ImportError: No module named docutils.core
Closed, ResolvedPublic

Description

integration-config-tox-py27 fails installing Zuul with the error:

Collecting python-daemon (from zuul->-r test-requirements.txt (line 3))
  Using cached python-daemon-2.0.1.tar.gz
    Traceback (most recent call last):
      File "<string>", line 20, in <module>
      File "/tmp/pip-build-DFmgwd/python-daemon/setup.py", line 27, in <module>
        import version
      File "version.py", line 51, in <module>
        import docutils.core
    ImportError: No module named docutils.core
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
    
      File "<string>", line 20, in <module>
    
      File "/tmp/pip-build-DFmgwd/python-daemon/setup.py", line 27, in <module>
    
        import version
    
      File "version.py", line 51, in <module>
    
        import docutils.core
    
    ImportError: No module named docutils.core
    
    ----------------------------------------
    Command "python setup.py egg_info" failed with error code 1

It causes all patches against integration/config.git to fail miserably.

Event Timeline

hashar created this task.Jan 12 2015, 8:57 AM
hashar raised the priority of this task from to Needs Triage.
hashar updated the task description. (Show Details)
hashar added a subscriber: hashar.

That affects OpenStack as well, the root cause is a missing dependency in python-daemon. The fix/workaround is to pin python-daemon <2.0

https://review.openstack.org/#/c/146350/

hashar added a comment.EditedJan 12 2015, 9:08 AM

I have merged in upstream patch in our Zuul work and tagged it wmf-deploy-20150112-1

*   d63faae - (HEAD, tag: wmf-deploy-20150112-1, wikimedia/master, wikimedia/labs, wm-master) Merge https://review.openstack.org/#/c/146350/2 (12 minutes ago) <Antoine Musso>
|\  
| * 0ccc974 - Pin python-daemon<2.0 (13 minutes ago) <Joshua Hesketh>
|/  
*   cbd7926 - (tag: wmf-deploy-20141221-2) merge https://review.openstack.org/#/c/128921/4/ (3 weeks ago) <Antoine Musso>

Seems to fix the problem. I am redeploying Zuul.

hashar closed this task as Resolved.Jan 12 2015, 9:25 AM
hashar claimed this task.

Fixed by picking up upstream change.