Page MenuHomePhabricator

After I remove a statement, the background of the property remains blue
Closed, ResolvedPublic

Description

After I remove a statement, the background of the property remains blue

doesn't happen when adding statements.

Details

Related Gerrit Patches:

Event Timeline

aude created this task.Mar 24 2015, 9:14 PM
aude raised the priority of this task from to Needs Triage.
aude updated the task description. (Show Details)
aude added a subscriber: aude.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 24 2015, 9:14 PM
Lydia_Pintscher triaged this task as High priority.Mar 25 2015, 9:32 AM
Lydia_Pintscher moved this task from incoming to ready to go on the Wikidata board.
Lydia_Pintscher added a subscriber: Lydia_Pintscher.

Change 227702 had a related patch set uploaded (by Jonas Kress (WMDE)):
Fixes: Property Background remains blue after removing statement

https://gerrit.wikimedia.org/r/227702

I fixed this, but I think it's still not the expected behavior, because when you edit two statements and remove or cancel one of them the background of the property turns back gray even though it should stay blue, because there is still one statement in edit mode.

aude added a comment.Jul 30 2015, 1:38 AM

@Jonas I think your patch is an improvement but agree the behevior is still a bit strange and inconsistent when editing multiple statements at the same time

Change 227702 merged by jenkins-bot:
Fixes: Property Background remains blue after removing statement

https://gerrit.wikimedia.org/r/227702

aude closed this task as Resolved.Jul 30 2015, 1:39 PM
aude removed a project: Patch-For-Review.

created T107422 for the general issue that the background turns to gray when editing multiple statements and saving/cancelling/removing one.