Page MenuHomePhabricator

Special characters menu in VisualEditor does not include en dash
Closed, ResolvedPublic1 Story Points

Description

I'm trying to use VisualEditor on dewiki, but the special characters menu (as shown after clicking the Omega icon) does not contain any dash at all. This seems to be one of the most important symbols editors need for their work.

Event Timeline

pajz created this task.Apr 11 2015, 8:06 PM
pajz raised the priority of this task from to Needs Triage.
pajz updated the task description. (Show Details)
pajz added a project: VisualEditor.
pajz added a subscriber: pajz.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 11 2015, 8:06 PM
Aklapper set Security to None.

This seems to be one of the most important symbols editors need for their work.

Is that a general statement, or maybe rather dewiki specific? For the latter I think that in theory, often used characters can be defined (if I understand T95856 correctly).

pajz added a comment.Apr 13 2015, 9:39 AM

Well, the need for an en dash may be stronger on dewiki, but in the dewiki special characters menu, I cannot find any dash character at all. And I don't think there's any Wiki that doesn't use any kind of dash. However, I do not know whether the menu varies from Wiki to Wiki, and/or if this is a local configuration issue and/or if there's a thought behind it (e.g. Wikis should use MediaWiki:Visualeditor-quick-access-characters.json because the relevant symbols will differ among Wikis), etc. But at any rate it's important the symbol is made available on dewiki.

pajz renamed this task from Special characters menu in VisualEditor does not include em dash to Special characters menu in VisualEditor does not include en dash.Apr 13 2015, 9:39 AM
matmarex claimed this task.Apr 21 2015, 8:39 AM

Change 205558 had a related patch set uploaded (by Bartosz Dziewoński):
Allow special characters with tooltip or that encapsulate text

https://gerrit.wikimedia.org/r/205558

VisualEditor-MediaWiki is now reusing the list of characters from the wikitext editor, but we were accidentally removing the dashes from it.

It wasn't accidental... these characters (7 of them, I think it was?) would not work as they did in WikiEditor until a VE core change was made to allow encapsulation rather than replacement.

The dashes would, as they don't encapsulate anything, they only had tooltips defined. I submitted patches to support that already, too (T65227, T70425).

matmarex triaged this task as Normal priority.Apr 22 2015, 9:05 PM

Change 205558 merged by jenkins-bot:
Allow special characters with tooltip or that encapsulate text

https://gerrit.wikimedia.org/r/205558