Page MenuHomePhabricator

Links to log RevDel entries don't work
Closed, ResolvedPublic

Description

When I (an administrator) follow the "more..." link for Revision Deletion actions, I get the "Invalid target revision" page, not the details of the RevDel action.

Event Timeline

OdMishehu raised the priority of this task from to Needs Triage.
OdMishehu updated the task description. (Show Details)
OdMishehu added a subscriber: OdMishehu.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 14 2015, 5:22 PM
Krenair added a comment.EditedApr 14 2015, 7:08 PM

If you take two of these broken Special:RevisionDelete URLs and merge the ids parameters, you get a result, with only one log entry showing...

Krenair added a comment.EditedApr 14 2015, 7:19 PM

ids[1580]=1&ids[1573]=1 is the format expected. Also accepts a comma-separated list of IDs
ids[0]=1580&ids[1]=1573 is what the links are using

Krenair added a comment.EditedApr 14 2015, 7:43 PM

I think this issue was caused by https://gerrit.wikimedia.org/r/#/c/152161/

MariaDB [mediawikiwiki_p]> select log_timestamp, log_params from logging where log_id in (2688476, 2828727);
+----------------+-----------------------------------------------------------------------------------------+
| log_timestamp  | log_params                                                                              |
+----------------+-----------------------------------------------------------------------------------------+
| 20150123131124 | 2676602,2672332,2672303,2672276,2672238
ofield=0
nfield=2                               |
| 20150301014449 | a:3:{s:6:"4::ids";a:1:{i:0;s:7:"2828718";}s:9:"5::ofield";s:1:"0";s:9:"6::nfield";i:1;} |
+----------------+-----------------------------------------------------------------------------------------+
2 rows in set (0.00 sec)
Krenair claimed this task.Apr 14 2015, 7:50 PM

Change 204102 had a related patch set uploaded (by Alex Monk):
Fix link to Special:RevisionDelete in newer log revdel logs

https://gerrit.wikimedia.org/r/204102

Legoktm set Security to None.

Change 204106 had a related patch set uploaded (by Alex Monk):
Fix link to Special:RevisionDelete in newer log revdel logs

https://gerrit.wikimedia.org/r/204106

Change 204102 merged by jenkins-bot:
Fix link to Special:RevisionDelete in newer log revdel logs

https://gerrit.wikimedia.org/r/204102

Change 204106 merged by jenkins-bot:
Fix link to Special:RevisionDelete in newer log revdel logs

https://gerrit.wikimedia.org/r/204106

Krenair closed this task as Resolved.Apr 14 2015, 8:28 PM