Page MenuHomePhabricator

git clone fails: zuul.eqiad.wmnet[0: 208.80.154.135]: errno=Connection timed out
Closed, ResolvedPublic

Description

16:46:40 Caused by: hudson.plugins.git.GitException: Command "clone --progress -o origin --depth 1 git://zuul.eqiad.wmnet/operations/mediawiki-config /mnt/jenkins-workspace/workspace/phplint" returned status code 128:
16:46:40 stdout: Cloning into '/mnt/jenkins-workspace/workspace/phplint'...
16:46:40 
16:46:40 stderr: fatal: unable to connect to zuul.eqiad.wmnet:
16:46:40 zuul.eqiad.wmnet[0: 208.80.154.135]: errno=Connection timed out

Event Timeline

hashar created this task.May 13 2015, 4:51 PM
hashar raised the priority of this task from to Unbreak Now!.
hashar updated the task description. (Show Details)
hashar added a subscriber: hashar.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 13 2015, 4:51 PM

The Zuul git repositories are served by a git-daemon process on gallium.wikimedia.org. Looking at the syslog messages there is a lot of:

May 13 16:54:00 gallium git-daemon[21163]: fatal: The remote end hung up unexpectedly
May 13 16:54:01 gallium git-daemon[21193]: fatal: The remote end hung up unexpectedly
May 13 16:54:02 gallium git-daemon[21196]: fatal: The remote end hung up unexpectedly
May 13 16:54:02 gallium git-daemon[21199]: fatal: The remote end hung up unexpectedly
May 13 16:54:02 gallium git-daemon[21202]: fatal: The remote end hung up unexpectedly
May 13 16:54:03 gallium git-daemon[21209]: fatal: The remote end hung up unexpectedly
May 13 16:54:03 gallium git-daemon[21213]: fatal: The remote end hung up unexpectedly

Also there seems to be a disruption on labs going on.

The traffic between labs and prod has been shortly interrupted due to an ongoing operation maintenance.

hashar closed this task as Resolved.May 13 2015, 5:02 PM
hashar claimed this task.

It is back up and solved. Might be interrupted again though.

To retrigger jobs just comment recheck in Gerrit.