Page MenuHomePhabricator

"Tickets" (defunct Bugzilla) vs "Maniphest" sections on korma are confusing
Closed, ResolvedPublic

Description

(Filing this as it's confusing, see e.g. T105634)

STEPS:

  1. Go to http://korma.wmflabs.org/browser/
  2. Expand the menu bar on the left
  3. See both "Tickets" (for defunct Bugzilla) and "Maniphest" sections

EXPECTED:
Either remove the "Tickets" section and keep the "Maniphest" section, or (probably better for consistency, seeing the generic titles of the other sections) move the content of the "Maniphest" section into the "Tickets" section ('overwrite').

Event Timeline

Aklapper created this task.Jul 16 2015, 3:19 PM
Aklapper raised the priority of this task from to Needs Triage.
Aklapper updated the task description. (Show Details)
Aklapper added a project: wikimedia.biterg.io.
Aklapper added a subscriber: Aklapper.
Aklapper triaged this task as Normal priority.Jul 16 2015, 3:21 PM
He7d3r added a subscriber: He7d3r.Jul 16 2015, 9:34 PM

Interesting - that "Maniphest" section is gone again now. So only "Tickets" left (which is Bugzilla and shows outdated data).

There is also both http://korma.wmflabs.org/browser/maniphest_response_time.html and http://korma.wmflabs.org/browser/bugzilla_response_time.html now. The latter should die.

Aklapper added subscribers: Dicortazar, Qgil.

General question: Should we keep Bugzilla statistics in korma for historical purpose? If yes, we should rename "Tickets" to "Bugzilla (defunct)" or something in the navigation and in page titles.

@Dicortazar: What's the "right" approach to get this fixed? I'm starring at https://github.com/Bitergia/mediawiki-dashboard/blob/master/browser/config/README which says to update project-info.json but reality seems to differ:

  1. Remove/rename the "its" entry from https://github.com/Bitergia/mediawiki-dashboard/blob/master/browser/config/menu-elements.json to remove/deprecate Bugzilla related stats?
  2. Or instead edit mediawiki-dashboard/browser/config/project-info.json which currently says
"its_url":"https://bugzilla.wikimedia.org/",
"its_name":"Mediawiki Product in Bugzilla",
"its_type":"bugzilla",

by updating this entry to be of type "maniphest"? (And would that be supported by the software?)
But then again I don't see Maniphest mentioned at all in https://github.com/Bitergia/mediawiki-dashboard/blob/master/browser/config/project-info.json though the README implies so...

Note to myself: This also affects the korma frontpage listing both "Ticket Participants" and "Maniphest participants" which is confusing.

@Dicortazar: What's the "right" approach to get this fixed?

I need feedback here from Bitergia to my previous comment on what's the correct approach, then I can try to give this a shot.

Aklapper set Security to None.

Edit mediawiki-dashboard/browser/config/project-info.json

Moved that part into T114636 - still needs feedback there.

Aklapper added a comment.EditedOct 5 2015, 9:32 AM

Replacing/updating the navigation sidebar strings seem to be less trivial, they seem to be defined in browser/lib/vizgrimoire.min.js?:
aux=mele.scm;aux_html=HTMLComposer.sideBarLinks("fa-code","Source code management","scm",aux)
I guess there is a better place than a file with minimized JS? Or maybe this is too complicated to maintain in the long run and should better not be done? @Dicortazar?

Aklapper claimed this task.Oct 20 2015, 4:45 PM
Aklapper lowered the priority of this task from Normal to Low.

@Dicortazar: Reply to T106037#1701576 and in T114636 about the correct approach (place in code) is welcome.

Looking at mediawiki-dashboard/browser/config/menu-elements.json the order in the side bar menu is:

  • scm
  • mls
  • irc
  • studies
  • its
  • maniphest
  • scr
  • wiki
  • extra

Looking at http://korma.wmflabs.org/browser/ the order in the side bar menu is:

  • scm
  • scr
  • its
  • maniphest
  • mls
  • irc
  • wiki
  • studies
  • extra

So I'd like to understand where this order is defined.

@Lcanasdiaz to take a look if we can have aliases for ITS in the navigation side bar (as "Tickets" might be hardcoded while "defunct Bugzilla" might be clearer).

Aklapper reassigned this task from Aklapper to Lcanasdiaz.Dec 18 2015, 10:42 PM

Added to the side bar.

I've also included this text on the Bugzilla overview.

"This panel is no longer updated. Information retrieved from a defunct Bugzilla"

Lcanasdiaz closed this task as Resolved.Feb 25 2016, 4:42 PM

I don't see that reflected yet in the side bar on korma.wmflabs.org but looking forward to it.

Any related code change(s) to link to?

I don't see that reflected yet in the side bar on korma.wmflabs.org but looking forward to it.

Hmmm, this is due to the cache of your browser. I've just tested it again :)

Any related code change(s) to link to?