Page MenuHomePhabricator

Stacktraces missing from exception.log on fluorine
Closed, ResolvedPublic

Description

2015-07-30 08:24:21 mw1053 wikidatawiki exception ERROR: [0e4f9934] /wiki/Special:WhatLinksHere/Wikidata:Tools   Flow\Exception\CatchableFatalErrorException from line 35 of /srv/mediawiki/php-1.26wmf16/extensions/Flow/includes/Model/WikiReference.php: Argument 6 passed to Flow\Model\WikiReference::__construct() must be an instance of Title, null given {"exception":"[object] (Flow\\Exception\\CatchableFatalErrorException(code: 0): Argument 6 passed to Flow\\Model\\WikiReference::__construct() must be an instance of Title, null given at /srv/mediawiki/php-1.26wmf16/extensions/Flow/includes/Model/WikiReference.php:35)"}

This seems to be a problem caused by https://gerrit.wikimedia.org/r/#/c/213348/

Event Timeline

bd808 created this task.Jul 30 2015, 4:41 PM
bd808 claimed this task.
bd808 raised the priority of this task from to High.
bd808 updated the task description. (Show Details)
bd808 added a project: MediaWiki-Debug-Logger.
bd808 added subscribers: bd808, Legoktm.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 30 2015, 4:41 PM
bd808 added a comment.Jul 30 2015, 4:45 PM

herp derp. We don't use LegacyLogger in WMF production. I need to update the WMF config to configure Monolog\Formatter\LineFormatter to print stack traces.

Change 228020 had a related patch set uploaded (by BryanDavis):
ObjectFactory: add support for setter injection

https://gerrit.wikimedia.org/r/228020

Change 228022 had a related patch set uploaded (by Legoktm):
ObjectFactory: add support for setter injection

https://gerrit.wikimedia.org/r/228022

Change 228023 had a related patch set uploaded (by BryanDavis):
logging: Enable stacktrace printing

https://gerrit.wikimedia.org/r/228023

Change 228020 merged by jenkins-bot:
ObjectFactory: add support for setter injection

https://gerrit.wikimedia.org/r/228020

Change 228022 abandoned by Legoktm:
ObjectFactory: add support for setter injection

https://gerrit.wikimedia.org/r/228022

Change 228053 had a related patch set uploaded (by BryanDavis):
Monolog: Add Formatter that uses MWExceptionHandler::getRedactedTraceAsString

https://gerrit.wikimedia.org/r/228053

Change 228053 merged by jenkins-bot:
Monolog: Add Formatter that uses MWExceptionHandler::getRedactedTraceAsString

https://gerrit.wikimedia.org/r/228053

Change 228850 had a related patch set uploaded (by Legoktm):
Monolog: Add Formatter that uses MWExceptionHandler::getRedactedTraceAsString

https://gerrit.wikimedia.org/r/228850

Change 228850 merged by jenkins-bot:
Monolog: Add Formatter that uses MWExceptionHandler::getRedactedTraceAsString

https://gerrit.wikimedia.org/r/228850

Change 228023 merged by jenkins-bot:
logging: Enable stacktrace printing

https://gerrit.wikimedia.org/r/228023

Change 233758 had a related patch set uploaded (by BryanDavis):
HHVM: enable user handler for fatals

https://gerrit.wikimedia.org/r/233758

Change 233758 merged by jenkins-bot:
HHVM: enable user handler for fatals

https://gerrit.wikimedia.org/r/233758

Change 233590 had a related patch set uploaded (by BryanDavis):
Enhance debug log output for stacktraces

https://gerrit.wikimedia.org/r/233590

Change 233590 merged by jenkins-bot:
Enhance debug log output for stacktraces

https://gerrit.wikimedia.org/r/233590

bd808 closed this task as Resolved.Oct 7 2015, 10:24 PM

I just checked exception.log on fluorine and it looks like all of the logged exceptions now have stacktrace information associated with them.