Page MenuHomePhabricator

Pasting text into the page edit area sometimes causes text below the paste to move up (which should never happen)
Closed, InvalidPublic

Description

Observed this on Wiktionary while using Chrome, but this is likely a generic problem.

Pasting text sometimes (not every time) causes text below the paste to move one line up, consuming the blank line below the paste (when there is one).

This is quite unconventional behavior, should never happen, and also requires an additional action to correct (usually adding the space back).

Event Timeline

Yurivict raised the priority of this task from to Needs Triage.
Yurivict updated the task description. (Show Details)
Yurivict added a subscriber: Yurivict.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 27 2015, 10:00 PM

Hi @Yurivict. For future reference, please associate at least one project with a task. See https://www.mediawiki.org/wiki/How_to_report_a_bug - thanks!

Is this about classic editing? Is this about VisualEditor? Is this about pasting plain text or formatted text? From where is the text pasted?

This needs better steps to reproduce. :-/

Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Wiktionary doesn't have VE (except for French and Swedish, and even then only as opt-in), so I'd assume it's WikiEditor?

This does sound a bit like the fun bug with Firefox and text-areas, actually.

Classic editor, not Visual, and chrome browser.

I will post the test case when I encounter this again. But I saw this many times.

How to reproduce:

  • Open any article in Wiktionary (classical editor)
  • Search for something in Google Books
  • Copy from the search results there
  • Paste it into the middle of the area of multiple blank lines in Wiktionary article
  • Observe how lines that are below the paste jump up

I think the triggering factor is the *styled* text being pasted.

  • Search for something in Google Books
  • Copy from the search results there

Example link welcome, and example "what to copy" and how to mark that.

Could not reproduce using instructions on Chrome 46.

Wikipedia says 46 is only dev preview version for Android. Are you on Android?

I am on desktop version 44.0.2403.155

Wikipedia says 46 is only dev preview version for Android. Are you on Android?

I don't know where on Wikipedia you found that. No.

https://en.wikipedia.org/wiki/Google_Chrome

Last stable release: 44.0.2403.128 (July 29, 2015; 30 days ago[2][3])

Beta
45.0.2454.78 (August 26, 2015; 2 days ago[6]) [±]

Dev
46.0.2490.6 (August 27, 2015; 1 day ago[7]) [±]

Beta for Android
45.0.2454.78 (August 26, 2015; 2 days ago[8]) [±]

Dev for Android
46.0.2490.4 (August 25, 2015; 3 days ago[9]) [±]

If you see that this has been fixed in the newer version then please close it. I don't have 46 available yet.

TheDJ closed this task as Invalid.Feb 23 2016, 5:02 PM
TheDJ added a subscriber: TheDJ.

I see something similar in Chrome 49.0.2623.54 beta (64-bit).

It indeed seems that if you paste rich text/html into a plain text textbook that it consumes one too many new lines. That's a clear upstream issue however, and not something that I think we should invest a lot of time into. It's just a minor thing. Anyone willing to report this upstream in Chrome is more than welcome of course.

Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptFeb 23 2016, 5:02 PM
GOIII moved this task from Backlog to Closed on the WikiEditor board.Apr 3 2016, 9:03 AM

This is still a problem in Chrome as of version 48.0.2564.97.