Page MenuHomePhabricator

Graphite `reqstats.` hierarchy is filled with apparently unused metrics for each of our wiki domains
Closed, DuplicatePublic

Description

While looking for Varnish error code statistics in Graphite under reqstates. I found out it is cluttered with metrics for each of our Wiki domain.

The related script is most probably files/udp2log/sqstat.pl in puppet which has been introduced 3 years ago by Asher. Each branch has three metrics: pageview, tp50 and tp99.

Since they seem empty, maybe we should phase them out? I am not sure whether sqstats.pl is still in use though.

Related Objects

Event Timeline

hashar created this task.Sep 3 2015, 8:32 AM
hashar raised the priority of this task from to Needs Triage.
hashar updated the task description. (Show Details)
hashar added subscribers: hashar, fgiunchedi, Ottomata, QChris.
Restricted Application added subscribers: Matanya, Aklapper. · View Herald TranscriptSep 3 2015, 8:32 AM
hashar closed this task as a duplicate of T83580: Overhaul reqstats.Sep 3 2015, 8:45 AM

Per @fgiunchedi , reqstats. is being overhauled: T83580: Overhaul reqstats.