Page MenuHomePhabricator

ResourcesTest::testFileExistence: File '/mnt/jenkins-workspace/workspace/mediawiki-extensions-hhvm/src/extensions/Flow/modules/styles/flow/icons/ajax-loader.gif' referenced by 'ext.flow.ui' must exist.
Closed, ResolvedPublic

Description

A new test for missing image files referenced from CSS I'm adding in https://gerrit.wikimedia.org/r/#/c/235903/ exposed an issue:

https://integration.wikimedia.org/ci/job/mediawiki-extensions-hhvm/30048/consoleFull:

00:50:20 3) ResourcesTest::testFileExistence with data set #1260 ('/mnt/jenkins-workspace/workspace/mediawiki-extensions-hhvm/src/extensions/Flow/modules/styles/flow/icons/ajax-loader.gif', 'ext.flow.ui', '/mnt/jenkins-workspace/workspace/mediawiki-extensions-hhvm/src/extensions/Flow/modules/styles/flow/icons/ajax-loader.gif')
00:50:20 File '/mnt/jenkins-workspace/workspace/mediawiki-extensions-hhvm/src/extensions/Flow/modules/styles/flow/icons/ajax-loader.gif' referenced by 'ext.flow.ui' must exist.
00:50:20 Failed asserting that file "/mnt/jenkins-workspace/workspace/mediawiki-extensions-hhvm/src/extensions/Flow/modules/styles/flow/icons/ajax-loader.gif" exists.
00:50:20 
00:50:20 /mnt/jenkins-workspace/workspace/mediawiki-extensions-hhvm/src/tests/phpunit/structure/ResourcesTest.php:24
00:50:20 /mnt/jenkins-workspace/workspace/mediawiki-extensions-hhvm/src/tests/phpunit/MediaWikiTestCase.php:131

You could probably be using jquery.spinner instead?

Details

Related Gerrit Patches:
mediawiki/extensions/Flow : masterRemove containing file as intended.
mediawiki/extensions/Flow : masterRemove dead code

Event Timeline

matmarex created this task.Sep 8 2015, 10:34 AM
matmarex raised the priority of this task from to High.
matmarex updated the task description. (Show Details)
matmarex added a subscriber: matmarex.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptSep 8 2015, 10:34 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 236978 had a related patch set uploaded (by Mattflaschen):
Remove dead code

https://gerrit.wikimedia.org/r/236978

Change 236978 merged by jenkins-bot:
Remove dead code

https://gerrit.wikimedia.org/r/236978

Change 236981 had a related patch set uploaded (by Mattflaschen):
Remove containing file as intended.

https://gerrit.wikimedia.org/r/236981

Change 236981 merged by jenkins-bot:
Remove containing file as intended.

https://gerrit.wikimedia.org/r/236981

Starting with https://integration.wikimedia.org/ci/job/mediawiki-extensions-hhvm/30049/testReport/(root)/ResourcesTest__testFileExistence/testFileExistence_with_data_set__1260/
the test for

File '/mnt/jenkins-workspace/workspace/mediawiki-extensions-hhvm/src/extensions/Flow/modules/styles/flow/icons/ajax-loader.gif' referenced by 'ext.flow.ui' must exist.
Failed asserting that file "/mnt/jenkins-workspace/workspace/mediawiki-extensions-hhvm/src/extensions/Flow/modules/styles/flow/icons/ajax-loader.gif" exists.

marked as Fixed, then Passed.

DannyH closed this task as Resolved.Sep 18 2015, 5:34 PM
DannyH added a subscriber: DannyH.