Page MenuHomePhabricator

Can't edit in mobile front end beta
Closed, ResolvedPublic

Description

The pencil icon for editing has disappeared from every page I've checked in mobile. The Desktop edit tab is still present and working on Desktop accessed via mobile device.

I'm using a Samsung Verizon Android Galaxy S-3, SCH-I535, OS v4.4.2

Event Timeline

Thnidu created this task.Oct 1 2015, 10:33 PM
Thnidu raised the priority of this task from to Needs Triage.
Thnidu updated the task description. (Show Details)
Thnidu added a subscriber: Thnidu.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 1 2015, 10:33 PM
Krenair added a subscriber: Krenair.

Shows up for me

Thnidu added a comment.Oct 2 2015, 1:06 AM

Not just the pencil: The blue block that's normally at the top of the page
and takes an extra second or two to appear -- "Add discussion" -- isn't
there either. Neither is the watchlist star. Attached: screenshot of my
mobile talk page.

But I DO see them when I open the same page (mobile talk page,
https://en.m.wikipedia.org/wiki/User_talk:Thnidu) on my laptop!

Thnidu

Thnidu added a comment.Oct 2 2015, 3:23 AM

Further data: My earlier reports were all using Firefox 41.0. I just tried
the Wikipedia Beta app: it DOES show the pencil icon and allows editing
with it. The watchlist star is absent, though.

Mobile App is unrelated to mobile website :)

So I'm confused... Is this app or web... if you are getting this issue on Firefox do you also get it on Chrome?

Your symptoms sound like a JS failure which could be due to a cache issue so let's rule that out.
Do you get this issue on all pages or just some pages?

Thnidu added a comment.EditedOct 2 2015, 4:06 PM

My initial report was about web, on smartphone.
Then I tried the app and got a different result per my last report (Fri, Oct 2, 3:23 AM): pencil visible and working, but no watchlist star.

I don't have Chrome on my smartphone.

Your symptoms sound like a JS failure which could be due to a cache issue so let's rule that out.

How? I know how to purge the cache on my laptop, but not on the Android

As I said in my initial report, "The pencil icon for editing has disappeared from every page I've checked in mobile" [via web, using Firefox as stated].

Thnidu added a comment.Oct 2 2015, 4:30 PM
This comment was removed by Thnidu.

Can you check in a private window (without being logged in) if you see the same issue?
If you can test on another browser on the same device that would also be useful

Do you have same issue on:
http://en.m.wikipedia.beta.wmflabs.org/wiki/UserMergesgtxkn?mobileaction=beta ?

Thnidu added a comment.Oct 2 2015, 5:52 PM

Can you check in a private window (without being logged in) if you see the same issue?

Yes, the same issue.

If you can test on another browser on the same device that would also be useful

I'll check later. It'll take time to download a different browser.

Do you have same issue on:
http://en.m.wikipedia.beta.wmflabs.org/wiki/UserMergesgtxkn?mobileaction=beta

?

There I can edit okay without logging in. The page looks good. BUT it will not let me log in. It keeps telling me there is no user by this name, either with or without initial capital letter. THAT is alarming. Is that page really Wikipedia or just a simulation?

Do you have same issue on:
http://en.m.wikipedia.beta.wmflabs.org/wiki/UserMergesgtxkn?mobileaction=beta

?
There I can edit okay without logging in. The page looks good. BUT it will not let me log in. It keeps telling me there is no user by this name, either with or without initial capital letter. THAT is alarming. Is that page really Wikipedia or just a simulation?

That's a beta wiki ("beta.wmflabs.org"), it does not have production accounts. If you have been giving it your production password, you need to go and change your password.

Thnidu added a comment.Oct 2 2015, 7:20 PM

Do you have same issue on:
  http://en.m.wikipedia.beta.wmflabs.org/wiki/UserMergesgtxkn?mobileaction=beta

That's a beta wiki ("beta.wmflabs.org"), it does not have production accounts. If you have been giving it your production password, you need to go and change your password.

OH SHIT, I WISH TO HELL YOU HAD TOLD ME THAT BEFORE SENDING ME TO THAT PAGE THAT SAYS "LOG IN." I am sick and tired of coming up with new passwords to memorize for all my accounts. – What do you mean by "production password"?

Jdlrobson triaged this task as Low priority.Oct 2 2015, 7:36 PM

You don't need to login to view that page.... I was just keen to understand if the bug was present there.
It sounds like the bug is to do with caching possibly on the server side given that you have the same issue in a private window. Let's keep an eye on this until next deployment... I know there were some Zero issues which might be causing this to happen

That's a beta wiki ("beta.wmflabs.org"), it does not have production accounts. If you have been giving it your production password, you need to go and change your password.

OH SHIT, I WISH TO HELL YOU HAD TOLD ME THAT BEFORE SENDING ME TO THAT PAGE THAT SAYS "LOG IN." I am sick and tired of coming up with new passwords to memorize for all my accounts. – What do you mean by "production password"?

I didn't send you there. I mean the password you use to log into your account on public Wikimedia wikis.

Thnidu added a comment.Oct 2 2015, 8:10 PM

Krenair, I apologize to you. It was Jdlrobson who asked me

Do you have same issue on:
http://en.m.wikipedia.beta.wmflabs.org/wiki/UserMergesgtxkn?mobileaction=beta

And since you-all had been asking whether I got the same problem whether I was logged in or not, it seemed like good practice to apply the same test there. Now I'm told I shouldn't have logged in with my Wikipedia pw (Oh?) and I have to come up with (yet) another one that's easy for me to remember and hard for a Black Hat to guess.

Sorry, communication failure all around. Just trying to get to the bottom of this issue and determine if this bug is impacting a significant amount of users. Am unable to replicate it on any of my test devices so I must assume caching in the meantime. Let's check in next week to see if the problem is still present.

@Krenair out of interest why would this need a password change? Do we surface this in logs somewhere or are you suggesting this it purely because it happened over non-https? I'm a little confused.

@Krenair out of interest why would this need a password change? Do we surface this in logs somewhere or are you suggesting this it purely because it happened over non-https? I'm a little confused.

beta is not trustworthy - non-https + no NDA requirement for server access etc.

Thnidu added a comment.Oct 2 2015, 9:02 PM

Given this lack of information and lack of communication, it would seem like an obvious idea to put up a big warning on that page, something like THIS SITE IS NOT SECURE. DO NOT USE ANY IMPORTANT PASSWORDS ON IT.

You folks may use phabricator and the associated stuff regularly, but I'm no admin, no hacker. I'm just a Wikipedia editor who spent a decent part of his career in software (but not writing software) and has the irritating habit of reporting problems when he finds them. And since Wikipedians who want to make bug reports or use Bugzilla are directed here, I am probably not the only one who will run into this problem.

Thnidu added a comment.Oct 2 2015, 9:18 PM

I just installed (presumably the latest) Chrome on my Android phone, and the results are intermediate. On my mobile talk page https://en.m.wikipedia.org/wiki/User_talk:Thnidu I see the pencil and the star, but not the "Add discussion" block:

https://drive.google.com/file/d/0B46BIYkqIBs0YWhzUHpyWTJGTW8/view?usp=docslist_api

Krenair added a comment.EditedOct 3 2015, 12:36 AM

Given this lack of information and lack of communication, it would seem like an obvious idea to put up a big warning on that page, something like THIS SITE IS NOT SECURE. DO NOT USE ANY IMPORTANT PASSWORDS ON IT.

The logo is different on the desktop version of the beta site, which should make it clear that you are not on an actual wikipedia. Obviously, you wouldn't give your Wikimedia password to any random non-WMF-hosted MediaWiki install. I'm not saying that it's less secure than most installations, just that it does not meet our standards for production.
And obviously, you shouldn't be giving important passwords to non-HTTPS sites, regardless of what they may or may not be. :)

Thnidu added a comment.EditedOct 3 2015, 1:40 AM

@Krenair wrote:

The logo is different on the desktop version of the beta site, which should make it clear that you are not on an actual wikipedia.

Fail. It's also different on Wikimedia Foundation, Wiktionary, Wikidata, Wikivoyage, and doubtless all the other Wikimedia sites (or projects or affiliates or whatever they're called). Should I be afraid to log in to some Wikimedium that WP sends me to just because I haven't heard of it?

Obviously, you wouldn't give your Wikimedia password to any random non-WMF-hosted MediaWiki install.

Is this non-secure development(?) site non-WMF hosted?

I'm not saying that it's less secure than most installations, just that it does not meet our standards for production.

But how is an ordinary Wikipedian (not an engineer or other kind of hacker), who comes here following WP's directions for reporting a bug, supposed to know that?

And obviously, you shouldn't be giving important passwords to non-HTTPS sites. :)

This I admit. But given the points above, I wasn't watching for an HTTP site. I trusted that I was still within WMF's secure family of sites, and I had no reason to think otherwise.

I'm sorry, but I have to put this in the same bin with all the times in my career when the engineers said You're not supposed to do that!, the beta testers (or in worst case the end-users) said How were we supposed to know?, the engineers said It's obvious!, and the victims said Maybe it is to you!

@Thnidu I'm really sorry about this. I've made things a little better for mobile (I've changed the warning message) and have opened a bug for desktop - T114552

Thnidu added a comment.Oct 3 2015, 3:29 AM

@Jdlrobson Thank you! I just saw the new bug report and the discussion already going on there. I'm very glad this is being handled.

Jdlrobson closed this task as Resolved.Nov 4 2015, 4:43 PM
Jdlrobson claimed this task.

Should be fixed. Note talk icon only shows to logged in users - see T54165