Links to talk pages in mobile view for all anonymous users
Open, NormalPublic

Description

The talk button on the Minerva skin is currently only visible to logged-in users whom have greater than 5 edits, or logged-out users who have opted-in to the beta setting. This differs from desktop which shows it unconditionally.

Original task report:

The mobile interface for wikipedia currently doesn't offer a link to the Talk/non-Talk page. Nor does it offer a clear link to the History page.

Request: add a thin set of tabs at the top of the page, as on the non-mobile interface. Include at least "Article/Project" "Talk".

Either offer a "History" tab (which would take you to the non-mobile interface, as currently), or move up the "last edited X days ago" line to be a subtitle, just below the title. If the latter, add the text "(see page history)" to make it clear that clicking on that text will display the history page.

This will make editing and interacting with the site via mobile much more rewarding. Thanks!

See Also:

This card tracks a proposal from the 2015 Community Wishlist Survey: https://meta.wikimedia.org/wiki/2015_Community_Wishlist_Survey

This proposal received 6 support votes, and was ranked #79 out of 107 proposals. https://meta.wikimedia.org/wiki/2015_Community_Wishlist_Survey/Talk_pages#Access_talk_pages_in_the_mobile_interface_from_main_article

Developer notes

Removing this logic would actually throw away a lot of code debt.
SkinMinerva has a method isTalkAllowed.
Removing this method and it's usages would show the talk button for everyone.

Details

Reference
bz52165

Related Objects

There are a very large number of changes, so older changes are hidden. Show Older Changes

Change 190728 merged by jenkins-bot:
Promote TalkOverlay to stable

https://gerrit.wikimedia.org/r/190728

Jdlrobson closed this task as Resolved.Jun 11 2015, 6:48 PM
Jdlrobson claimed this task.
Restricted Application added a subscriber: Luke081515. · View Herald TranscriptJul 3 2015, 11:41 PM
Tbayer renamed this task from Links to talk pages in mobile view to Show links to talk pages in mobile view for experienced users (>5 edits).Jul 7 2015, 8:43 PM

Since the task description has caused some misunderstadings, I have amended it post mortem to clarify that in production this change only applies to logged-in users with >5 edits (per https://gerrit.wikimedia.org/r/#/c/190728/ ).

Nemo_bis renamed this task from Show links to talk pages in mobile view for experienced users (>5 edits) to Links to talk pages in mobile view.Jul 8 2015, 5:44 AM
Nemo_bis reopened this task as Open.

Better restore the original one.

DannyH removed a subscriber: DannyH.Jul 8 2015, 9:30 PM
Jdlrobson updated the task description. (Show Details)Aug 4 2015, 6:42 PM
Jdlrobson renamed this task from Links to talk pages in mobile view to Links to talk pages in mobile view for all users.
Jdlrobson removed a project: Patch-For-Review.
Jdlrobson moved this task from Backlog to Discussing on the MobileFrontend board.
MaxSem removed a subscriber: MaxSem.Aug 18 2015, 5:11 PM
Quiddity updated the task description. (Show Details)Sep 11 2015, 11:23 PM
Elitre added a subscriber: Elitre.Oct 21 2015, 5:50 PM

Is resolving this task really just a matter of removing a conditional?

Is resolving this task really just a matter of removing a conditional?

Seems so: https://github.com/wikimedia/mediawiki-extensions-MobileFrontend/blob/master/includes/skins/SkinMinerva.php#L931-L948. Let's find out.

Is resolving this task really just a matter of removing a conditional?

yes. But I don't think, that the blocker is on the code size, I thought until now, that no-one knows, if the feature should be enabled for all users in stable mode, too. @Jdlrobson, @JKatzWMF, @bmansurov, @phuedx, @Jhernandez?

@Florian, I'm not sure why minimum 5 edits were required either. I think we should strive for desktop parity.

@bmansurov As far as I know, it was a requirement to get the talk button merged into stable. From my side, we don't need such a minimum edit count or any other barrier.

Nemo_bis reopened this task as Open.Jan 16 2016, 12:37 PM

There is no apparent relationship between this report and T119412. T119412#1896035 claims the respective code changes are live, but there are no talk page links.

Jdlrobson updated the task description. (Show Details)Jan 18 2016, 2:16 AM
Jdlrobson renamed this task from Links to talk pages in mobile view for all users to Links to talk pages in mobile view for all anonymous users.
IMPORTANT: If you are a community developer interested in working on this task: The Wikimedia Hackathon 2016 (Jerusalem, March 31 - April 3) focuses on #Community-Wishlist-Survey projects. There is some budget for sponsoring volunteer developers. THE DEADLINE TO REQUEST TRAVEL SPONSORSHIP IS TODAY, JANUARY 21. Exceptions can be made for developers focusing on Community Wishlist projects until the end of Sunday 24, but not beyond. If you or someone you know is interested, please REGISTER NOW.
Restricted Application added a subscriber: JEumerus. · View Herald TranscriptJan 21 2016, 2:53 PM

This probably isn't appropriate as a hackathon project, as it's basically just a config change. The only blocker as far as I know is getting consensus to implement the change.

Oh, I think there's consensus :) At least, it's one of the Community wishes with 6 positive and 1 negative votes (ok, it's not what I would call "huge involvement", but I take what I get :P) (source), so this is only blokced by technical concerns, as far as I know (which are older then 1 year, iirc). I think, it wouldn't be a big problem to initiate a test on a medium-Wikipedia (or maybe only enwiki as one large Wikipedia), turn this feature on and look, how the people respond to that (we could collect some feedback on a feedback page and announce this page on something like Village pump). Thoughts?

Btw.: I'm feeling bad, that this (simple?) task is open for more then one year, so it would be great to finish this in a good way :D

kaldari added a subscriber: TheDJ.Jan 22 2016, 11:27 PM

I believe @TheDJ had some concerns about implementing this, but I don't remember exactly what.

DannyH updated the task description. (Show Details)Feb 6 2016, 12:26 AM
Qgil removed a subscriber: Qgil.Feb 11 2016, 12:32 PM

Re: discussion of consensus, I think we need to think about readers in addition to editor needs on this as the reason to hide from logged out was to prevent naive readers from stepping unknowingly into a confusing experience.

However, I think we can move forward once a few talk glitches have been ironed out. About to add 2 blockers to that end.

Dvorapa added a subscriber: Dvorapa.May 1 2017, 6:53 PM
TheDJ added a comment.Sep 30 2017, 8:37 PM

@kaldari my concern about this was mostly: T116686

But since we are unable to get anywhere with discussion pages, and since this has already been open for 3 years (longer in other forms actually), I don't think that that problem outweighs the one where people don't have access to talk pages at all, right ?

I propose we just flip the switch. I have a slight fear we might see lots of complaints about vandalized talk pages, but communities can set a filter to block edits from mobile edits rather easily.

Cirdan added a subscriber: Cirdan.Apr 29 2018, 8:15 AM
Jdlrobson raised the priority of this task from Low to Normal.Jul 5 2018, 6:24 PM
Jdlrobson added a subscriber: Aschroet.
Jdlrobson added subscribers: alexhollender, ovasileva.

@ovasileva given this came up again and dates back to 2013 maybe we can just do this? I've never been convinced that hiding the talk page link to anons is a good idea. cc @alexhollender

@Jdlrobson maybe we could add some kind of info/disclaimer element for logged out people? E.g.

Jdlrobson removed Jdlrobson as the assignee of this task.

But please make clear that a talk page isn't a online comment section…

But please make clear that a talk page isn't a online comment section…

Agreed. Let's take extra care with the copy here

Jdlrobson edited projects, added goodfirstbug; removed Regression.Jul 6 2018, 10:09 PM
Jdlrobson updated the task description. (Show Details)
JKatzWMF removed a subscriber: JKatzWMF.Jul 10 2018, 2:55 AM