Page MenuHomePhabricator

TalkOverlay build false talk links
Closed, ResolvedPublic

Description

Originally reported by Mark Mandel here: https://bugzilla.wikimedia.org/show_bug.cgi?id=52165#c12

CONTEXT:
I use the mobile site, '''betatest version''', on a Samsung Galaxy S3 smartphone (model SCH-I535, Android v. 4.4.2). When I go to my user page via the menu at the top left (bottom option, square smiley-face) I get the small RECENT ACTIVITY page, which has at the bottom a link
'''Visit user page'''
and a button
''[speech balloons icon]'' '''Talk to Thnidu'''
Both of those take me where they say they will. So far, so good.

BUG:
The user page itself also has a speech balloons icon just under the title, along with the pencil and star icons ("edit" and "watchlist"). When I tap that I get

X Talk Add discussion
There are no conversations about this page

which is patently false. If I tap "Read as wiki page" at the bottom, I get

'''User talk:User:Thnidu'''
Return to the user page of "User:Thnidu".
This page doesn't exist. Why not be bold and create it?

Accessing the normal website with my laptop, I find no comparable problem.

ANALYSIS:
Of course, my user talk page is '''User talk:Thnidu'''. Evidently the mobile beta speech balloons icon, when tapped on a user page, ''prefixes'' "User talk:" to the complete name of the user page instead of ''replacing'' "User" with "User talk".


Version: unspecified
Severity: normal

Details

Reference
bz73476

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:46 AM
bzimport added a project: MobileFrontend-beta.
bzimport set Reference to bz73476.
bzimport added a subscriber: Unknown Object (MLST).
Florian created this task.Nov 15 2014, 8:41 PM

bingle-admin wrote:

Prioritization and scheduling of this bug is tracked on Trello card https://trello.com/c/MdEP0kt5

Change 173541 had a related patch set uploaded by Florianschmidtwelzow:
Get talk page name from title object

https://gerrit.wikimedia.org/r/173541

Change 173541 merged by jenkins-bot:
Get talk page name from title object

https://gerrit.wikimedia.org/r/173541

gerritadmin wrote:
Change 173541 merged by jenkins-bot:
Get talk page name from title object
https://gerrit.wikimedia.org/r/173541

So, I gather, the bug has been closed as fixed. And indeed, the speech-balloon button on my mobile beta userpage now takes me to my talk page. Hurray! Thank you all.
But the TALK page has a speech-balloon button. It seems to be no-op, but it shouldn't be there at all. I'll start a new bug.

Can't replicate the problem (that the talk button takes you to the talk page, instead of the overlay). Please give more details, e.g. an example URL :)

As I said before, I am a user, not a wiki programmer. I know nothing of this "overlay" of which you keep speaking.

And, as I also said before, please reread my comment carefully. I said that THE TALK PAGES THEMSELVES NOW HAVE DUMMY "SPEECH BALLOONS" BUTTONS, WHICH LOOK AS IF THEY WOULD TAKE YOU TO, E.G., Talk:Talk:Article-name (BUT WHICH ACTUALLY DON'T DO ANYTHING).

Hello,

sorry, i see no reason to cry :( I read your answer, so i will quote you to make clear, what i mean:

And indeed, the speech-balloon button on my mobile beta userpage now takes me to my talk page. Hurray! Thank you all.

That is _not_ intended (if you really will be redirected to your talk page, e.g. Talk:Uername). It should open an "overlay" (like the editor, an overlay, which fills the entire scceen). Look at the screenshot for an example:

And, as I also said before, please reread my comment carefully. I said that THE TALK PAGES THEMSELVES NOW HAVE DUMMY "SPEECH BALLOONS" BUTTONS, WHICH LOOK AS IF THEY WOULD TAKE YOU TO, E.G., Talk:Talk:Article-name (BUT WHICH ACTUALLY DON'T DO ANYTHING).

That is not what you said! In my comment i just answered your first sentence. Please reread your comment, especially the last words:

But the TALK page has a speech-balloon button. It seems to be no-op, but it shouldn't be there at all. I'll start a new bug.

That's why i was waiting for this new bug report (and haven't said anything to this part of your comment) to answer there and connect my change with it. I can reproduce the problem and submitted a patch for it: https://gerrit.wikimedia.org/r/#/c/176326/
So, sorry, but it seems, that we misunderstood each other, right?

Paladox set Security to None.
Restricted Application added a project: Readers-Web-Backlog. · View Herald TranscriptMay 13 2015, 8:37 PM