Page MenuHomePhabricator

Edit post and Summarize fail in firefox
Closed, ResolvedPublic

Description

Edit post and Summarize menu handlers fail and direct the user to the ns-js experience (where they it fails).

09:25:28.186 "[Exception... "Failure"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: http://127.0.0.1:8080/w/load.php?debug=false&lang=en&modules=ext.flow%7Cext.flow.components%2Cdm%2Ceditor%2Ctemplating%2Cui%7Cext.flow.jquery.conditionalScroll%2CfindWithParent%7Cext.flow.vendor.storer%7Cext.uls.init%2Cinterface%2Cpreferences%2Cwebfonts%7Cext.visualEditor.desktopArticleTarget.init%7Cext.visualEditor.track%2Cve%7Cjquery.byteLength%2Ccookie%2CtabIndex%2Cthrottle-debounce%2Ctipsy%7Cmediawiki.Title%2CUri%2Capi%2Ccldr%2Ccookie%2CjqueryMsg%2Clanguage%2Ctemplate%2Cuser%7Cmediawiki.api.options%7Cmediawiki.language.data%2Cinit%7Cmediawiki.libs.pluralruleparser%7Cmediawiki.page.startup%7Cmediawiki.template.handlebars%2Cregexp%7Cmoment%2Coojs%2Coojs-ui%7Coojs-ui.styles%7Coojs-ui.styles.icons%2Cicons-editing-advanced%2Cindicators%2Ctextures%7Cskins.vector.js%7Cuser.defaults&skin=vector&version=e5d1e0eeefc8 :: OO.ui.TextInputWidget.prototype.selectRange :: line 698"  data: no]" Exception { message: "", result: 2147500037, name: "NS_ERROR_FAILURE", filename: "http://127.0.0.1:8080/w/load.php?de…", lineNumber: 698, columnNumber: 0, inner: null, data: null, stack: "OO.ui.TextInputWidget.prototype.selectRange@http://127.0.0.1:8080/w/load.php?debug=false&lang=en&modules=ext.flow%7Cext.flow.components%2Cdm%2Ceditor%2Ctemplating%2Cui%7Cext.flow.jquery.conditionalScroll%2CfindWithParent%7Cext.flow.vendor.storer%7Cext.uls.init%2Cinterface%2Cpreferences%2Cwebfonts%7Cext.visualEditor.desktopArticleTarget.init%7Cext.visualEditor.track%2Cve%7Cjquery.byteLength%2Ccookie%2CtabIndex%2Cthrottle-debounce%2Ctipsy%7Cmediawiki.Title%2CUri%2Capi%2Ccldr%2Ccookie%2CjqueryMsg%2Clanguage%2Ctemplate%2Cuser%7Cmediawiki.api.options%7Cmediawiki.language.data%2Cinit%7Cmediawiki.libs.pluralruleparser%7Cmediawiki.page.startup%7Cmediawiki.template.handlebars%2Cregexp%7Cmoment%2Coojs%2Coojs-ui%7Coojs-ui.styles%7Coojs-ui.styles.icons%2Cicons-editing-advanced%2Cindicators%2Ctextures%7Cskins.vector.js%7Cuser.defaults&skin=vector&version=e5d1e0eeefc8:698:675
OO.ui.TextInputWidget.prototype.moveCursorToEnd@http://127.0.0.1:8080/w/load.php?debug=false&lang=en&modules=ext.flow%7Cext.f"[…] }1 load.php:177:542
log() load.php:177
handler() load.php:155
jQuery.Callbacks/fire() load.php:45
jQuery.Callbacks/self.fireWith() load.php:46
jQuery.Callbacks/self.fire() load.php:46
mw.track() load.php:155
execute/runScript() load.php:162
execute/</checkCssHandles() load.php:163
execute() load.php:163
handlePending() load.php:159
execute/runScript/markModuleReady() load.php:162
execute/runScript/<() load.php:162
jQuery.Callbacks/fire() load.php:45
jQuery.Callbacks/self.add() load.php:45
.Deferred/promise.always() load.php:46
execute/runScript() load.php:162
execute/</checkCssHandles() load.php:163
execute/</cssHandle/<() load.php:163
jQuery.Callbacks/fire() load.php:45
jQuery.Callbacks/self.fireWith() load.php:46
jQuery.Callbacks/self.fire() load.php:46
fireCallbacks() load.php:157
addEmbeddedCSS() load.php:158
addEmbeddedCSS/<() load.php:157

Details

Related Gerrit Patches:

Event Timeline

SBisson created this task.Nov 4 2015, 2:29 PM
SBisson raised the priority of this task from to Unbreak Now!.
SBisson updated the task description. (Show Details)
SBisson added a subscriber: SBisson.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 4 2015, 2:29 PM

Change 251175 had a related patch set uploaded (by Mattflaschen):
Fix regression in edit post and edit topic summary due to OO UI changes

https://gerrit.wikimedia.org/r/251175

Change 251175 merged by jenkins-bot:
Fix regression in edit post and edit topic summary due to OO UI changes

https://gerrit.wikimedia.org/r/251175

Change 251183 had a related patch set uploaded (by Mattflaschen):
Fix regression in edit post and edit topic summary due to OO UI changes

https://gerrit.wikimedia.org/r/251183

Change 251183 merged by jenkins-bot:
Fix regression in edit post and edit topic summary due to OO UI changes

https://gerrit.wikimedia.org/r/251183

Checked in betalabs.

Catrope closed this task as Resolved.Nov 22 2015, 10:36 PM
Catrope added a subscriber: Catrope.