Page MenuHomePhabricator

Special:Nearby has broken hybrid styles for mw.notify
Closed, ResolvedPublic

Description

When triggering mw.notify from a user script or MediaWiki core module (e.g. global events unrelated to the current page), something strange happens if currently on Special:Nearby.

Expected:

Something like this

Actual:

A dark fullscreen overlay with a bright bubble containing unreadable white text.

Details

Related Gerrit Patches:
mediawiki/extensions/MobileFrontend : masterFix mobile.toast styles in desktop skins

Event Timeline

Krinkle created this task.Dec 4 2015, 2:07 PM
Krinkle raised the priority of this task from to Needs Triage.
Krinkle updated the task description. (Show Details)
Krinkle added a subscriber: Krinkle.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptDec 4 2015, 2:07 PM
Jdlrobson triaged this task as High priority.Dec 4 2015, 6:04 PM
Jdlrobson added a subscriber: Jdlrobson.

yuck. These styles should be only loaded in Minerva so not quite sure why this is happening.

Florian claimed this task.Dec 4 2015, 6:40 PM
Florian added a subscriber: Florian.

That's a dependency to mobile.toast for mobile.watchlist, which is a dependency of mobile.pagelist.scripts. mobile.pagelist.scripts is needed by mobile.nearby and therefor loaded in mobile.special.nearby.scripts, too.

Change 256964 had a related patch set uploaded (by Florianschmidtwelzow):
Fix mobile.toast styles in desktop skins

https://gerrit.wikimedia.org/r/256964

Change 256964 merged by jenkins-bot:
Fix mobile.toast styles in desktop skins

https://gerrit.wikimedia.org/r/256964

Jdlrobson closed this task as Resolved.Dec 7 2015, 4:53 PM

This has greatest a regression: 120671
There may be other regressions due to toasts not styling in other places where notifications are caused by special pages that exist in MobileFrontend and use toast code.