Page MenuHomePhabricator

Notice: Undefined index in LinkNormalizer.php
Closed, ResolvedPublic

Description

[Wed Dec 16 21:07:50 2015] [hphp] [10318:7f35d07ff700:350686:000001] [] \nNotice: Undefined index: 0 in /srv/mediawiki/tags/2015-12-16_07:54:21/extensions/Echo/includes/formatters/LinkNormalizer.php on line 17
[Wed Dec 16 21:07:50 2015] [hphp] [10318:7f35d07ff700:350686:000002] [] \nNotice: Undefined index: 1 in /srv/mediawiki/tags/2015-12-16_07:54:21/extensions/Echo/includes/formatters/LinkNormalizer.php on line 18
[Wed Dec 16 21:07:52 2015] [hphp] [10318:7f35cc3ff700:350737:000001] [] \nNotice: Undefined index: 0 in /srv/mediawiki/tags/2015-12-16_07:54:21/extensions/Echo/includes/formatters/LinkNormalizer.php on line 17
[Wed Dec 16 21:07:52 2015] [hphp] [10318:7f35cc3ff700:350737:000002] [] \nNotice: Undefined index: 1 in /srv/mediawiki/tags/2015-12-16_07:54:21/extensions/Echo/includes/formatters/LinkNormalizer.php on line 18

Likely caused by
"GET /w/api.php?action=query&format=json&notsections=alert&meta=notifications&notgroupbysection=1&notmessageunreadfirst=1&notformat=model&notlimit=25&notprop=index%7Clist%7Ccount&uselang=de&_=1450296389540 HTTP/1.1" 200 643 "https://translatewiki.net/wiki/Special:Watchlist"

Related Objects

View Standalone Graph
This task is connected to more than 200 other tasks. Only direct parents and subtasks are shown here. Use View Standalone Graph to show more of the graph.
StatusAssignedTask
OpenNone
Resolvedmatthiasmullie

Event Timeline

Nikerabbit updated the task description. (Show Details)
Nikerabbit raised the priority of this task from to Needs Triage.
Nikerabbit added a project: Notifications.
Nikerabbit added a subscriber: Nikerabbit.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptDec 16 2015, 8:11 PM
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald Transcript
Catrope triaged this task as High priority.Dec 19 2015, 1:22 AM
matthiasmullie closed this task as Resolved.Jan 12 2016, 10:16 PM
matthiasmullie claimed this task.
matthiasmullie added a subscriber: matthiasmullie.

https://gerrit.wikimedia.org/r/#/c/263739/ just removed this class.
This error, however, indicates that method getPrimaryLink() in the PresentationModel of some type of notification is incorrect somewhere.

By now, I believe all WMF extensions have been updated to reflect the current format, so this *should* be fixed (unless I missed an extensions or it's 3rd party)
In the event there was another extension that has not been updated, the notice will no longer happen in LinkNormalizer, but elsewhere.