Page MenuHomePhabricator

Increased line height when use formula inside a paragraph
Closed, ResolvedPublic

Description

I noticed that the line height of paragraphs are increased when they contained in MathML rendered formulas. This error for example occurs on the page https://de.wikibooks.org/wiki/Mathe_f%C3%BCr_Nicht-Freaks:_Cauchy-Kriterium_f%C3%BCr_Reihen#Herleitung_des_Cauchy-Kriteriums

I use Firefox 43.0 on Ubuntu.

Steps to reproduce the error:

  1. visit https://test2.wikipedia.org/wiki/Main_Page
  2. open a random page and save a long paragraph with inline formulas

Result:

Event Timeline

Kulla created this task.Dec 24 2015, 2:00 PM
Kulla raised the priority of this task from to Needs Triage.
Kulla updated the task description. (Show Details)
Kulla added projects: Math, Mathoid.
Kulla added a subscriber: Kulla.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptDec 24 2015, 2:00 PM

... mh I can not reproduce that in the first place

fredw added a subscriber: fredw.Dec 24 2015, 3:09 PM

This is a bug in the Latin Modern Math version distributed by Ubuntu.
You should ask your distro maintainer to upgrade to version 1.959. See
https://bugs.launchpad.net/ubuntu/+source/lmodern/+bug/1502701. For now,
you can install the latest version from the official web site.

@fredw: Thanks for the information.

I guess this bug will be fixed in the future by Ubuntu in one of the next releases. Thus I would set the priority to "low". I hope that's okay...

Kulla triaged this task as Low priority.Dec 25 2015, 10:39 AM
Kulla set Security to None.

Note that this is already fixed in Debian testing. I'm note familiar
with Ubuntu process and how they import Debian's packages but the next
release Ubuntu 16.04 LTS will be published next April:
https://en.wikipedia.org/wiki/List_of_Ubuntu_releases#Ubuntu_16.04_LTS_.28Xenial_Xerus.29

Kulla added a comment.Mar 27 2016, 3:15 PM

Info: The Bug is fixed in the current Ubuntu 15.10 (I had the bug in Ubuntu 15.04)...

Kulla added a comment.Apr 1 2016, 10:02 AM

Update: The bug is still present in Ubuntu 15.10. It occurs after installing the package texlive-latex-recommended. I hope, it will be fixed in Ubuntu 16.04...

Kulla added a comment.Apr 1 2016, 11:55 AM

I noticed, that the bug occurs on Ubuntu 15.10 after installing the package fonts-lmodern. Because this package is a dependency of texlive-latex-recommended the bug occurs when texlive is installed on Ubuntu 15.10. I will report whether this bug is fixed in Ubuntu 16.04...

Debenben closed this task as Resolved.Nov 11 2018, 8:05 PM
Debenben claimed this task.
Debenben added a subscriber: Debenben.

I think this was a problem of MathML and is fixed in newer firefox versions.