Page MenuHomePhabricator

"No infusion data found: catlinks" Error on OOUI special pages (e.g. Special:PasswordReset)
Closed, ResolvedPublic

Description

If I open an OOUI special page in beta labs (and locally, too), I'll get this error in the console:

Exception in load-callback in module mediawiki.widgets:
Error: No infusion data found: catlinks Error: No infusion data found: catlinks(…) load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=fuKFKEwW:177

e.g.:
http://en.wikipedia.beta.wmflabs.org/wiki/Special:PasswordReset

Details

Related Gerrit Patches:

Event Timeline

Florian created this task.Jan 7 2016, 4:42 PM
Florian claimed this task.
Florian raised the priority of this task from to High.
Florian updated the task description. (Show Details)
Florian added a subscriber: Florian.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 7 2016, 4:42 PM
Florian added subscribers: TheDJ, Jdlrobson.EditedJan 7 2016, 4:45 PM

Seems to be caused by: Id944029df180c80502840c118a58013ebb717e1f, fixing now.

Change 262907 had a related patch set uploaded (by Florianschmidtwelzow):
Fix Race-Condition in mediawiki.page.ready OOJs-UI infusion

https://gerrit.wikimedia.org/r/262907

Change 262907 merged by jenkins-bot:
Fix Race-Condition in mediawiki.page.ready OOJs-UI infusion

https://gerrit.wikimedia.org/r/262907

Florian closed this task as Resolved.Jan 7 2016, 6:46 PM

Aaaaaand: Fixed :)