Page MenuHomePhabricator

Add portal namespace to ZIM
Closed, InvalidPublic

Description

Hi,
I'm a sysop in Arabic Wikipedia. I'm not a programmer so I'm gonna try to explain exactly my needs to avoid any misunderstanding.
I'd like to have portals while navigating offline in Kiwix. Kiwix team told me that it's made seperatly by language.
So what I'm asking is to add portal namespace into the content namespaces (https://www.mediawiki.org/wiki/Manual:$wgContentNamespaces) in the Arabic projects when creating ZIMs for offline use.

Please feel free to modify the description if it's not clear.

Event Timeline

Helmoony created this task.Feb 22 2016, 8:29 PM
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptFeb 22 2016, 8:29 PM
Kelson added a subscriber: Kelson.Feb 22 2016, 8:30 PM

This seems to be still pending. Kiwix would be one of the benefactor, but there is nothing we can do to implement that task. The sysadmin of Wikimedia need to change WPAR configuration. @Helmoony, do you have a community decision about this?

Restricted Application added subscribers: JEumerus, Matanya. · View Herald TranscriptOct 16 2016, 7:45 PM
Urbanecm claimed this task.Oct 17 2016, 4:57 AM
Restricted Application added a project: User-Urbanecm. · View Herald TranscriptOct 17 2016, 4:57 AM
Urbanecm triaged this task as Medium priority.Oct 17 2016, 4:57 AM

Please give us a link to a community discussion which approve this.

Okay, so I'll wait two weeks and then process it. I'll prepare a patch for this a moment ago but it will be processed after two weeks.

Okay, confirmed by a 'crat. Please tell me how should be the namespace called in your language. Or do you wish English name "Portal"?

@Urbanecm I think there is a misunderstanding here. It's not about creating a new namespace, but about configuring an existing namesapce as "content namespace".

Okay, this is really misunderstanding. Which namespace should be set as content?

wgCanonicalNamespace : "بوابة",
wgNamespaceNumber : 100

@Urbanecm I guess NS_PORTAL is defined...

@Urbanecm @Kelson We just want to include the namespace PORTAL (arabic : بوابة) as a content namespace for ZIM only in ALL Arabic wikimedia projects. Please, be sure to don't add ns=100 as a content namespace for Arabic wikimedia projects (to avoid increasing the number of pages in Arabic projects - https://ar.wikipedia.org/w/index.php?title=Special:AllPages&hideredirects=1 -).

Thank you

Community approval link : https://ar.wikipedia.org/wiki/%D9%88%D9%8A%D9%83%D9%8A%D8%A8%D9%8A%D8%AF%D9%8A%D8%A7:%D8%A7%D9%84%D9%85%D9%8A%D8%AF%D8%A7%D9%86/%D8%A7%D9%82%D8%AA%D8%B1%D8%A7%D8%AD%D8%A7%D8%AA/%D8%A7%D9%84%D8%AD%D8%A7%D9%84%D9%8A%D8%A9#.D8.A7.D9.84.D8.A8.D9.88.D8.A7.D8.A8.D8.A7.D8.AA_.D9.81.D9.8A_.D9.83.D9.8A.D9.88.D9.8A.D9.83.D8.B3

Urbanecm added a comment.EditedOct 23 2016, 12:31 PM

Okay, I understood now.

Update form me: I was searching how to do this. It is possible to only set NS_PORTAL as content namespace. This will add it to ZIM too. It is not possible to add it only to ZIM.

Is this what you want?

@Urbanecm yes, you are right.

Urbanecm added a comment.EditedNov 20 2016, 5:10 PM

@Kelson Are you a member of the community? I only ask because I don't know if this is a community consent:).

Urbanecm changed the task status from Open to Stalled.Nov 20 2016, 5:11 PM
Urbanecm lowered the priority of this task from Medium to Low.

Waiting till reply of the community.

@Urbanecm @Kelson If it's not possible to add it only to ZIM then please don't do it. Portals are not considered part of our 450 000 content pages as mentionned above « Please, be sure to don't add ns=100 as a content namespace for Arabic wikimedia projects ».

Urbanecm closed this task as Invalid.Nov 20 2016, 6:35 PM

Okay, so closing as invalid. Adding anything only to ZIM isn't possible.

Restricted Application added a subscriber: alanajjar. · View Herald TranscriptSep 14 2019, 3:23 PM