Page MenuHomePhabricator

browsertests-MultimediaViewer-mediawiki.org-linux-firefox-sauce fails with "757: unexpected token"
Closed, ResolvedPublic

Description

browsertests-MultimediaViewer-mediawiki.org-linux-firefox-sauce/889 fails with

00:00:07.524       757: unexpected token at '<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
00:00:07.524       <html><head>
00:00:07.524       <title>301 Moved Permanently</title>
00:00:07.524       </head><body>
00:00:07.524       <h1>Moved Permanently</h1>
00:00:07.524       <p>The document has moved <a href="http://www.mediawiki.org/w/api.php">here</a>.</p>
00:00:07.524       </body></html>
00:00:07.524       ' (JSON::ParserError)

Details

Related Gerrit Patches:
mediawiki/extensions/MultimediaViewer : wmf/1.27.0-wmf.16Browser test: update mw.org tag to use canonical URL
mediawiki/extensions/MultimediaViewer : masterBrowser test: update mw.org tag to use canonical URL
integration/config : masterAdjust mediawiki_url for MultimediaViewer
mediawiki/extensions/MultimediaViewer : wmf/1.27.0-wmf.15Fix browsertests-MultimediaViewer-mediawiki.org-linux-firefox-sauce Jenkins job
mediawiki/extensions/MultimediaViewer : masterFix browsertests-MultimediaViewer-mediawiki.org-linux-firefox-sauce Jenkins job
mediawiki/selenium : masterWIP T128079
mediawiki/ruby/api : masterWIP T128079
integration/config : masterWIP Fix browsertests-MultimediaViewer-mediawiki.org-linux-firefox-sauce

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 25 2016, 3:11 PM

Change 273234 had a related patch set uploaded (by Zfilipin):
WIP Fix browsertests-MultimediaViewer-mediawiki.org-linux-firefox-sauce

https://gerrit.wikimedia.org/r/273234

Change 273234 abandoned by Zfilipin:
WIP Fix browsertests-MultimediaViewer-mediawiki.org-linux-firefox-sauce

Reason:
Does not fix the problem.

https://gerrit.wikimedia.org/r/273234

Reproduced on my machine:

$ MEDIAWIKI_ENVIRONMENT=mediawiki-org MEDIAWIKI_PASSWORD=not-the-real-one bundle exec cucumber features/mmv.download.feature:7
@integration @en.wikipedia.beta.wmflabs.org @firefox @chrome @internet_explorer_9 @internet_explorer_10 @internet_explorer_11 @safari @test2.wikipedia.org
Feature: Download menu

  Background:                             # features/mmv.download.feature:4
    Given I am viewing an image using MMV # features/step_definitions/mmv_steps.rb:21
      757: unexpected token at '<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
      <html><head>
      <title>301 Moved Permanently</title>
      </head><body>
      <h1>Moved Permanently</h1>
      <p>The document has moved <a href="http://www.mediawiki.org/w/api.php">here</a>.</p>
      </body></html>
      ' (JSON::ParserError)
      ./features/step_definitions/mmv_steps.rb:4:in `/^I am at a wiki article with at least two embedded pictures$/'
      ./features/step_definitions/mmv_steps.rb:22:in `/^I am viewing an image using MMV$/'
      features/mmv.download.feature:5:in `Given I am viewing an image using MMV'

  Scenario: Download menu can be opened   # features/mmv.download.feature:7
    When I click the download icon        # features/step_definitions/mmv_download_steps.rb:8
    Then the download menu should appear  # features/step_definitions/mmv_download_steps.rb:54

Failing Scenarios:
cucumber features/mmv.download.feature:7 # Scenario: Download menu can be opened

1 scenario (1 failed)
3 steps (1 failed, 2 skipped)
0m0.769s

Working fine when targeting beta:

$ MEDIAWIKI_ENVIRONMENT=beta MEDIAWIKI_PASSWORD=not-the-real-one bundle exec cucumber features/mmv.download.feature:7
@integration @en.wikipedia.beta.wmflabs.org @firefox @chrome @internet_explorer_9 @internet_explorer_10 @internet_explorer_11 @safari @test2.wikipedia.org
Feature: Download menu

  Background:                             # features/mmv.download.feature:4
    Given I am viewing an image using MMV # features/step_definitions/mmv_steps.rb:21

  Scenario: Download menu can be opened   # features/mmv.download.feature:7
    When I click the download icon        # features/step_definitions/mmv_download_steps.rb:8
    Then the download menu should appear  # features/step_definitions/mmv_download_steps.rb:54

1 scenario (1 passed)
3 steps (3 passed)
0m13.419s

Change 274973 had a related patch set uploaded (by Zfilipin):
WIP T128079

https://gerrit.wikimedia.org/r/274973

Change 274973 had a related patch set uploaded (by Zfilipin):
WIP T128079

https://gerrit.wikimedia.org/r/274973

Change 274975 had a related patch set uploaded (by Zfilipin):
WIP T128079

https://gerrit.wikimedia.org/r/274975

Change 274976 had a related patch set uploaded (by Zfilipin):
WIP T128079

https://gerrit.wikimedia.org/r/274976

Change 274973 abandoned by Zfilipin:
WIP T128079

Reason:
Not needed, the fix is https://gerrit.wikimedia.org/r/#/c/274976/

https://gerrit.wikimedia.org/r/274973

Change 274975 abandoned by Zfilipin:
WIP T128079

Reason:
Not needed, the fix is https://gerrit.wikimedia.org/r/#/c/274976/

https://gerrit.wikimedia.org/r/274975

Change 274976 merged by jenkins-bot:
Fix browsertests-MultimediaViewer-mediawiki.org-linux-firefox-sauce Jenkins job

https://gerrit.wikimedia.org/r/274976

Change 275495 had a related patch set uploaded (by Hashar):
Fix browsertests-MultimediaViewer-mediawiki.org-linux-firefox-sauce Jenkins job

https://gerrit.wikimedia.org/r/275495

Change 275495 merged by jenkins-bot:
Fix browsertests-MultimediaViewer-mediawiki.org-linux-firefox-sauce Jenkins job

https://gerrit.wikimedia.org/r/275495

Jdlrobson added a subscriber: Jdlrobson.

Still appears to be failing :(

@Jdlrobson: unfortunately, the shell script that executes tests somehow messes up environment variables. The job will be fixed when T128190 is resolved.

Change 276415 had a related patch set uploaded (by Hashar):
Adjust mediawiki_url for MultimediaViewer

https://gerrit.wikimedia.org/r/276415

Jenkins job updated. Still fails due to CUCUMBER_PARAMETER=@www.mediawiki.org which match no scenario.

Change 276415 merged by jenkins-bot:
Adjust mediawiki_url for MultimediaViewer

https://gerrit.wikimedia.org/r/276415

Change 276417 had a related patch set uploaded (by Hashar):
Browser test: update mw.org tag to use canonical URL

https://gerrit.wikimedia.org/r/276417

Change 276418 had a related patch set uploaded (by Hashar):
Browser test: update mw.org tag to use canonical URL

https://gerrit.wikimedia.org/r/276418

Change 276417 merged by jenkins-bot:
Browser test: update mw.org tag to use canonical URL

https://gerrit.wikimedia.org/r/276417

Change 276418 merged by jenkins-bot:
Browser test: update mw.org tag to use canonical URL

https://gerrit.wikimedia.org/r/276418

Adjusted the job to hit the canonical URL www.mediawiki.org and have adjusted the cucumber tag.

Now https://integration.wikimedia.org/ci/job/browsertests-MultimediaViewer-www.mediawiki.org-linux-firefox-sauce/909/console fails with a NeedCaptcha (MediawikiApi::CreateAccountError).

zeljkofilipin closed this task as Resolved.Mar 10 2016, 1:28 PM