Page MenuHomePhabricator

Create a Lua infobox template for books that use wikidata metadata based on work/edition
Closed, InvalidPublic

Description

Many Wikipedias use template:Infobox book that contains metadata
https://www.wikidata.org/wiki/Q5858283

However this is stored on wiki, and not on wikidata. Ideally a new template should use the work/edition distinction and fetch the data from Wikidata, according to the fields defined on
https://www.wikidata.org/wiki/Wikidata:WikiProject_Books

Ideally this data should also be used by Wikisource and eventually by Commons.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 3 2016, 9:01 AM
iecetcwcpggwqpgciazwvzpfjpwomjxn renamed this task from Create a Lua infobox template for books that used wikidata metadata based on work/edition to Create a Lua infobox template for books that use wikidata metadata based on work/edition.Mar 3 2016, 9:11 AM
Krenair added a subscriber: Krenair.

The current lua modules can call the pertinent data into templates, so not understanding why another module makes a difference, or improvement.

Lydia_Pintscher moved this task from incoming to monitoring on the Wikidata board.May 3 2016, 10:41 AM
Ankry added a subscriber: Ankry.May 5 2016, 7:01 AM
thiemowmde triaged this task as Low priority.Sep 5 2016, 3:06 PM
thiemowmde added a project: patch-welcome.
thiemowmde added a subscriber: thiemowmde.

I believe this is nothing the Wikidata team can do at the moment. Can you please edit and clarify the description?

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptApr 16 2019, 6:36 AM
Aklapper updated the task description. (Show Details)Apr 16 2019, 7:42 AM
Aklapper reopened this task as Open.

@Micru: This task is not invalid ("when the problem is not a bug, or when it is a change that is outside the power of the component's developers") until there are specific reasons provided.

thiemowmde closed this task as Invalid.Apr 24 2019, 1:00 PM
  • It was the author of this task who closed it.
  • The task description was not very specific and actionable to begin with.
  • This is something the Wikisource community can better manage on-wiki. I don't think they need this ticket to be able to do what the task asks for.
Ankry removed a subscriber: Ankry.Apr 24 2019, 1:19 PM