nowiki added around ISBN for unclear reason
Closed, DuplicatePublic

Description

I fixed with this edit a broken ISBN syntax. And VE wrapped then <nowiki>...</nowiki> around even that ISBN syntax was correct now. No idea why :-(

Raymond created this task.Mar 24 2016, 9:45 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 24 2016, 9:45 AM
Aklapper renamed this task from nowiki added aroung IBSN for unclear reaon to nowiki added around ISBN for unclear reason.Mar 24 2016, 12:53 PM
Esanders closed this task as Invalid.Mar 27 2016, 1:12 PM
Esanders added a subscriber: Esanders.

Because ISBNs get autolinked by the parser, so if what you typed into VE was an un-linked ISBN it needs to be <nowiki>'d.

However if you press space after typing an ISBN it should auto-link it in VE too.

I am not convinced that this task is invalid. Please see the initial diff: I repaired a broken ISBN syntax. My expectation to the VE is, that the ISBN is autolinked now.

I did, and I explained the cause. It is still possible to type an unlinked ISBN which is what happened. In order for that to stay unlinked it get's <nowiki>'d.

I have seen nowikied ISBNs in articles created by new users with ve. I very much doubt that this was intentional by the user or the user even knows about nowiki. there seems to be an error in ve.

Umherirrender reopened this task as Open.Apr 8 2016, 8:58 PM
Umherirrender added a subscriber: Umherirrender.

Please change the behaviour of the Visual Editor to autolinking an ISBN, RFC or PMID by default without any extra key press.

This would match the behaviour of the old wikitext editor and it is the more expected behaviour.
In the old wikitext editor you have to explicit type nowiki to make it unlinked, this should be done her too.