Page MenuHomePhabricator

Blurry icons in the Transclusion dialog
Closed, InvalidPublic1 Story Points

Description

All the icons (especially [[ ]], ( i ), and the bin) are slightly bigger than normally and look like blurred a little. I have Firefox 45, size 100%, Ubuntu 15.10.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 17 2016, 1:12 AM

I have a hunch it has something to do with the transform: scale(1) CSS property on the dialog frame (which we use for the fancy fade-in effect when opening the dialog). I couldn't reproduce what you're seeing, but I poked at a few things and noticed that transform: scale(1) (as opposed to transform: none) changes the rendering in my Firefox slightly (and they should both look exactly the same), shifting some elements around by 1 pixel.

Firefox 46.0b2 on Windows 7: (open these in new browser tabs and switch between them to compare)

transform: scale(1);transform: none;

@tarlocesilion: Since I can't reproduce, let's try debugging remotely a bit. :) Can you try following the steps in this video:

and see if the icons render correctly afterwards?

They do, but... not all of them :/ let's take ( i ) as an example. Most of the dots over ( i )s are clearly 1x1px, but some of them are bigger/blurred/faded. I think the change you suggested doesn't affect those icons that are next to 'required' parameters.

Jdforrester-WMF triaged this task as Normal priority.Apr 19 2016, 7:11 PM
Jdforrester-WMF set the point value for this task to 1.
Jdforrester-WMF moved this task from To Triage to TR0: Interrupt on the VisualEditor board.
Jdforrester-WMF added a subscriber: TerraCodes.
matmarex renamed this task from Too big icons in the Transclusion dialog to Blurry icons in the Transclusion dialog.Apr 20 2016, 5:43 PM
Volker_E added a subscriber: Volker_E.EditedOct 24 2016, 8:17 AM

(Was) Probably related to T130691@tarlocesilion did you later run into this problem again? Patch T94494 that might have positively affected, got merged on 19 April 2016 and was several days later.

Volker_E closed this task as Invalid.EditedMar 1 2017, 12:33 AM

No activity on this task for 10 months, excluding my last comment. Can't reproduce this, therefore closing as invalid. If new insights are given, let's reopen it.