Page MenuHomePhabricator

[BUG] WDQS GUI auto completion doesn't work with unicode
Closed, ResolvedPublic

Description

Right now, we can display property hints in given language, but completion still works only in English. We may want to make completion work in current language instead.

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a project: Discovery. · View Herald TranscriptApr 21 2016, 5:54 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Sorry, could you provide steps to reproduce?
I18N still needs the translations to be pushed from translatewiki to work.

Smalyshev moved this task from Needs triage to WDQS on the Discovery board.Apr 21 2016, 8:23 PM
  1. I switch language to Russian
  2. I load the Cats example
  3. I try to replace wdt:P31 with wdt:P279. When I start typing "под" which is the beginning of its Russian label (подкласс от) the right property is not found, however when I type "subclass" it is found. The tooltip correctly displays Russian label & description.

OK, thanks.

I guess the problem is:
line.charAt( pos ).match( /\w/ ) in hint.Rdf

Jonas renamed this task from WDQS GUI completion should work in current language to [BUG] WDQS GUI auto completion doesn't work in lang ru.Apr 22 2016, 8:25 AM
Lydia_Pintscher triaged this task as Low priority.Apr 25 2016, 9:59 AM
Lydia_Pintscher moved this task from incoming to ready to go on the Wikidata board.
Jonas renamed this task from [BUG] WDQS GUI auto completion doesn't work in lang ru to [BUG] WDQS GUI auto completion doesn't work with unicode.Apr 25 2016, 11:25 AM

Same problem with French. I tried to search for wd:île (island) and it didn't work.

Change 287656 had a related patch set uploaded (by Jonas Kress (WMDE)):
Fix: WDQS GUI auto completion doesn't work with unicode

https://gerrit.wikimedia.org/r/287656

Change 287656 merged by jenkins-bot:
Fix: WDQS GUI auto completion doesn't work with unicode

https://gerrit.wikimedia.org/r/287656

Jonas closed this task as Resolved.May 11 2016, 8:29 PM
Jonas claimed this task.