Page MenuHomePhabricator

[mobile] JSON displayed when editing Flow page
Closed, ResolvedPublic

Description

Split from T130322: [regression wmf.9] 'Edit title' pencil icon displayed as protected unnecessarily when viewing Flow page in MobileFrontend #4
The Flow pages have a big edit pencil icon displayed at the top of the page - see the screenshot. Clicking on it will display e.g.

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 2 2016, 10:28 PM

This should probably be in Q4, to make sure people can't just put arbitrary JSON and corrupt the page.

Change 286545 had a related patch set uploaded (by Mattflaschen):
Don't show edit link if editing is not supported for content handler

https://gerrit.wikimedia.org/r/286545

In T134206#2258185, @Mattflaschen wrote:

This should probably be in Q4, to make sure people can't just put arbitrary JSON and corrupt the page.

This couldn't happen, since editing was blocked by core with no-direct-editing.

The patch hides the link.

Mattflaschen-WMF renamed this task from [mobile] JASON displayed when editing Flow page to [mobile] JSON displayed when editing Flow page.May 2 2016, 11:28 PM
Mattflaschen-WMF claimed this task.

Change 286545 merged by jenkins-bot:
Don't show edit link if editing is not supported for content handler

https://gerrit.wikimedia.org/r/286545

Checked in betalabs and media.m.mediawiki.org - the link for editing flow content is removed; other editing means can are functioning normally.

jmatazzoni closed this task as Resolved.May 12 2016, 5:43 PM