Page MenuHomePhabricator

Upload Wizard for Wikimedia Commons does not complete process, freezes after last click, if only one file was selected
Closed, ResolvedPublic

Description

  1. Open upload Wizard in Safari
  2. Follow all instructions to upload the attached file
  3. Click on the last "Next" button
  4. I should see a spinning gear, and the messages (progressively) "Queued", something, "Publishing", followed by "Thanks for uploading!"
  5. What I see is the static picture on the attached screenshot

I am using Mac OS 10.11.4 and Safari 9.1. I get the same result with Chrome Version 50.0.2661.94 (64-bit).

Just for protocol the same problem appears using Window7/Opera.

Event Timeline

Restricted Application added subscribers: Zppix, Steinsplitter, Aklapper. · View Herald TranscriptMay 13 2016, 12:51 AM
matmarex added a project: UploadWizard.
matmarex updated the task description. (Show Details)
Restricted Application added a project: Multimedia. · View Herald TranscriptMay 13 2016, 12:59 AM
LacoR updated the task description. (Show Details)May 13 2016, 12:23 PM
Restricted Application added a subscriber: Matanya. · View Herald TranscriptMay 13 2016, 12:23 PM
LacoR added a subscriber: LacoR.May 13 2016, 12:24 PM
matmarex added subscribers: Nemo_bis, darthbhyrava, JGS25 and 4 others.

I'm sorry, this is a bug caused by a really stupid mistake I made in 189a5572cc08ac46dc0dba1f7293d5967ee8c7ba, which was deployed to Commons yesterday evening. The upload would always fail if you selected only one file (uploads of multiple files would succeed, which is presumably why we missed it in testing, and why we didn't notice the fall in numbers of files being uploaded with UploadWizard).

I have already deployed a workaround to Commons: https://commons.wikimedia.org/w/index.php?title=MediaWiki:Common.js&diff=196165190&oldid=190856441 and the issue should be fixed there. I'll have the proper patch deployed on Monday (and I'll revert the MediaWiki:Common.js workaround).

Change 288610 had a related patch set uploaded (by Bartosz Dziewoński):
uw.controller.Details: Fix 'Uncaught TypeError: Cannot read property '$element' of undefined'

https://gerrit.wikimedia.org/r/288610

matmarex renamed this task from Upload Wizard for Wikimedia Commons does not complete process, freezes after last click to Upload Wizard for Wikimedia Commons does not complete process, freezes after last click, if only one file was selected.May 13 2016, 2:24 PM
matmarex triaged this task as Unbreak Now! priority.
Restricted Application added subscribers: Luke081515, TerraCodes, Urbanecm. · View Herald TranscriptMay 13 2016, 2:24 PM

Change 288610 merged by jenkins-bot:
uw.controller.Details: Fix 'Uncaught TypeError: Cannot read property '$element' of undefined'

https://gerrit.wikimedia.org/r/288610

Change 288715 had a related patch set uploaded (by Bartosz Dziewoński):
uw.controller.Details: Fix 'Uncaught TypeError: Cannot read property '$element' of undefined'

https://gerrit.wikimedia.org/r/288715

TerraCodes added a comment.EditedMay 14 2016, 3:54 AM

I think this is related but I'm not 100% sure.
https://en.wikipedia.org/wiki/User_talk:Antonybarkur#Image_upload_error

I am getting the following error while uploading an image: Unknown error: "{"xhr":{"readyState":4,"responseText":"'origin' parameter does not match Origin header\n","status":403,"statusText":"Forbidden"},"textStatus":"error","exception":"Forbidden

Nemo_bis removed a subscriber: Nemo_bis.May 14 2016, 9:32 AM

No, it's not related.

This comment was removed by Lokal_Profil.

Change 288715 merged by jenkins-bot:
uw.controller.Details: Fix 'Uncaught TypeError: Cannot read property '$element' of undefined'

https://gerrit.wikimedia.org/r/288715

matmarex closed this task as Resolved.May 17 2016, 2:36 AM
matmarex removed a project: Patch-For-Review.