Page MenuHomePhabricator

HTTP 502 Bad Gateway error when trying to log into my bot in JUPYTER
Closed, ResolvedPublic

Description

Please Help me. I had changed my bot name. Error becomes as

502 Bad Gateway

nginx/1.9.4

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 14 2016, 3:13 PM

Please provide basic information that allows reproducing the problem (old bot name; new bot name; how and where you log in) - see https://www.mediawiki.org/wiki/How_to_report_a_bug . Thanks!

  1. Go to https://paws.wmflabs.org/paws/hub/login with Google Chrome.
  2. Click Sign in with MediaWiki button
  3. Login with maathavanbot account (*already login in jupyter with the account TamizhBOT through MediaWiki and changed it account name as Maathavanbot. )
  4. It goes to OAuth. I clicked allow.
  5. error becomes as :-

502 Bad Gateway

nginx/1.9.4

Thanks for adding those steps!

@Aklapper What can I do? if there any way?

yuvipanda triaged this task as High priority.May 19 2016, 2:54 PM
yuvipanda added a subscriber: yuvipanda.

Thank you for reporting this! Am looking into this right now.

@Maathavan does this work for you now?

I have had to restart all the notebooks due to some NFS issues. Re-logging in should work now. Apologies for the issues!

@yuvipanda It doesn't works. same reply.

Can you try logging in in a different browser?

@yuvipanda No, I'd tried in Safari and Google Chrome. Same result.

Its works to Maathavan Account, But didn't work to Maathavanbot.

If it work by deleting TamizhBOT's Server.

@Maathavan when I try to sign in now, I also get the 503. But if I perform a hard refresh of the page (shift + f5 or ctrl + f5) it seems to fix itself. Can you try that?

Also can you clarify if TamizhBOT works or not? I see it is logged in.

TamizhBOT's account was deleted. I already work with that account in Tamilwiki workshop. Its work.

I tried hard refresh of the page. but it does not seems to fix itself.

Can you give me the exact name of the account that is failing to work?

(I can also talk in tamil if that is easier for you!)

Maathavanbot என்ற கணக்கே வேலை செய்யவில்லை.

மன்னிக்கவும், வேரு வெலை அதிகமாகி விட்டது.

Maathavanbot என்ற கணக்கை டெலீட் செய்து விட்டேன். இபோ டிரய் பன்னுன்க? அதன் பழ்ய பயனர் பெயர் என்ன?

மன்னிக்கவும், வேரு வெலை அதிகமாகி விட்டது.
Maathavanbot என்ற கணக்கை டெலீட் செய்து விட்டேன். இபோ டிரய் பன்னுன்க? அதன் பழ்ய பயனர் பெயர் என்ன?

Hey Yuvi, Seems the account TamizhBOT got globally renamed to Maathavanbot. So after the rename, it seems he is not able to login to Maathavanbot. TamizhBOT OAuth Preference might get copied to Maathavanbot and it might be breaking something?
btw தமிழ்ல தட்டச்சு பண்ண ரொம்ப கஷ்டப் பட்டிருப்பீங்க போல? :P

@Maathavan I think I've fixed this now finally. Can you try again?

One month later:
@yuvipanda, @Maathavan, any news here?
And who should this be assigned to?

Well, looks like that particular user account still can not log in, and I haven't had time to look into it yet. I'm on vacation for a week now, so maybe I can look at it after?

Any news here? Still an issue? Or resolved in the meantime?

Is this still a problem?

Framawiki added a subscriber: Framawiki.EditedApr 20 2017, 6:42 PM

@Aklapper As no commits was pushed on on Github since many months, I suppose that this issue is not resolved right now.

@yuvipanda Are you agree if we merge T135306: HTTP 502 Bad Gateway error when trying to log into my bot in JUPYTER as duplicate with this task ? I suppose that they come from the same problem, because of username change.

Not only by me, few others too, Still facing the issue as mentioned below
https://phabricator.wikimedia.org/T140525

Aklapper renamed this task from I can't login my bot in JUPYTER to HTTP 502 Bad Gateway error when trying to log into my bot in JUPYTER.Jul 21 2017, 10:07 AM

@Maathavan Is this still a problem for you? I could look into it if it is.

Chicocvenancio closed this task as Resolved.Mar 2 2018, 5:17 PM
Chicocvenancio claimed this task.