Page MenuHomePhabricator

Image could not be trimmed
Closed, ResolvedPublic

Description

https://hu.wikipedia.org/wiki/Hej,_igaz%C3%ADtsad_j%C3%B3l_a_l%C3%A1bod (rev. 17570400) shows this error:

Image could not be trimmed:
/bin/bash: /usr/local/bin/mediawiki-firejail-convert: No such file or directory
Set $wgScoreTrim=false if this problem persists.

Event Timeline

Tgr created this task.Jun 1 2016, 12:09 AM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 1 2016, 12:09 AM
Ato_01 added a subscriber: Ato_01.Jun 2 2016, 10:33 AM

/usr/local/bin/mediawiki-firejail-convert is from $wgImageMagickConvertCommand and surely there would be more breakage if that was wrong... so maybe the problem is that this should be executed on the image scalers but actually runs on the appservers?

@Tgr The wrapper is currently only installed on the image scalers, but there actually seem to be extensions which shell out to imagemagick on the app servers (On fluorine I find two such failed calls for huwiki). I'm not sure whether these extensions should actually rather be running the the image scalers, but for now the straightforward fix is to also provide firejail and the wrapper on the application servers as well.

I'll revert the wmf-config change for now, so that this can be sorted out properly.

matmarex added a subscriber: Bonvol.
matmarex added a subscriber: matmarex.

https://gerrit.wikimedia.org/r/#/c/292337/

[13:39] <logmsgbot> !log jmm@tin Synchronized wmf-config/CommonSettings.php: disable firejail security hardening for image scalers, needs more work for the Score extension (duration: 00m 36s)

matmarex removed a subscriber: matmarex.Jun 2 2016, 11:52 AM
MoritzMuehlenhoff closed this task as Resolved.Jun 2 2016, 11:55 AM
MoritzMuehlenhoff claimed this task.

This has been reverted, sorry for the noise. I'll doublecheck with the Score extension before re-enabling.

Thank you, it works (confirmed on example from T136818)

Ato_01 removed a subscriber: Ato_01.Jun 3 2016, 6:23 AM