phabricator is not allowing you to be logged out to view phabricator
Closed, ResolvedPublic

Description

Steps to reproduce

Actual results

  • It brings up the log in screen instead of showing the dashbored for phabricator.

Expected results

  • It should show the phabricator dashbored without having to log in.
Paladox created this task.Jun 2 2016, 11:02 AM
Restricted Application added subscribers: Zppix, TerraCodes, Aklapper. · View Herald TranscriptJun 2 2016, 11:02 AM
Paladox triaged this task as Unbreak Now! priority.Jun 2 2016, 11:04 AM

Changing to ubreak since I just wanted to quickly do something without having to log in. Please change status if I'm wrong to have it as unbreak.

Restricted Application added subscribers: Luke081515, Urbanecm. · View Herald TranscriptJun 2 2016, 11:04 AM

Seems going to phabricator.wikimedia.org/diffusion so it may be someone changed permission on one of the dashbored's things. https://phabricator.wikimedia.org/dashboard/manage/1/

Aklapper closed this task as Resolved.Jun 2 2016, 11:16 AM
Aklapper claimed this task.

Argh. I am very sorry. Fixed now.

@Aklapper thanks for fixing it :)

My own stupidity - default for new panels is "Visible To: All Users" instead of "Public" and I didn't double-check that when I created the CoC heads-up panel (which was proposed in https://www.mediawiki.org/wiki/Talk:Code_of_Conduct/Draft#Wider_participation.2C_still ) and added it to the default frontpage dashboard. Grmpf...

@Aklapper it's ok. I carn't remember the task for allowing us to describe different user policy for dashbored without affecting logged out users. Maybe that should be given I high priority.