Page MenuHomePhabricator

Unchecking Styled (Wikitable) does not change the table property
Closed, ResolvedPublic1 Story Points

Description

Steps to reproduce:

  1. Open a page with VE which has a table in it with the option Styled (Wikitable) checked.
  2. Uncheck the option Styled (Wikitable) from table properties
  3. Click on Save page
  4. Go to Review your changes

Observe that, nothing has changed , after saving the page the property goes back to checked state.

Details

Related Gerrit Patches:
mediawiki/extensions/VisualEditor : masterTest removing all table classes
VisualEditor/VisualEditor : masterDon't restore class attribute on class attribute nodes

Event Timeline

Ryasmeen created this task.Jun 29 2016, 1:32 AM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 29 2016, 1:32 AM
Jdforrester-WMF changed the task status from Open to Stalled.Jun 29 2016, 11:03 AM

It does for me on Beta Cluster (testing just now). Do you have a particular page on which this happened?

Ryasmeen changed the task status from Stalled to Open.Jun 29 2016, 4:59 PM

It happens for all pages, although you need to change the property for an existing table on the page which has the option enabled already. Changing the steps.

Ryasmeen updated the task description. (Show Details)Jun 29 2016, 5:00 PM

Seems to work in cases when the table is also sortable - so looks like the bug is with settings the class list to empty.

Change 296720 had a related patch set uploaded (by Esanders):
Don't restore class attribute on class attribute nodes

https://gerrit.wikimedia.org/r/296720

Change 296722 had a related patch set uploaded (by Esanders):
Test removing all table classes

https://gerrit.wikimedia.org/r/296722

Change 296720 merged by jenkins-bot:
Don't restore class attribute on class attribute nodes

https://gerrit.wikimedia.org/r/296720

Jdforrester-WMF closed this task as Resolved.Jun 30 2016, 4:42 PM
Jdforrester-WMF assigned this task to Esanders.
Jdforrester-WMF triaged this task as Medium priority.
Jdforrester-WMF set the point value for this task to 1.

Change 296722 merged by jenkins-bot:
Test removing all table classes

https://gerrit.wikimedia.org/r/296722