Page MenuHomePhabricator

Email being rejected by the Education mailing list
Closed, ResolvedPublic

Description

Multiple emails from multiple senders who are subscribed to the list and not sending spam, are being rejected from the Education mailing list with the reason "Message rejected by filter rule match". This has been happening for a few days. I believe that a few months ago there was a similar problem with this same mailing list. Please investigate and fix.

Event Timeline

Pine created this task.Aug 1 2016, 6:51 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 1 2016, 6:51 PM
Dzahn updated the task description. (Show Details)Aug 1 2016, 7:26 PM
Dzahn added a subscriber: FloorKoudijs.

Education list run by janbart at wikimedia.org, fkoudijs at wikimedia.org, tflanagan at wikimedia.org

Pine added a comment.Aug 1 2016, 7:44 PM

Floor no longer works at WMF and Jan-Bart is no longer on the Board. :) Perhaps tflanagan will consider appointing some new list admins at some point.

Dzahn added a comment.Aug 1 2016, 7:51 PM

Yep, i don't know if that means they can't be list admins or if the admin password has changed. I would just recommend that there is consistency between the people listed as running the list and the ones who actually know the current password.

Dzahn added a comment.Nov 9 2016, 10:10 PM

@Pine Meanwhile the admins are just tflanagan@ janbart@. They have anti-spam settings on https://lists.wikimedia.org/mailman/admin/education/privacy/spam but please can you ask them directly to fix it or point them to this ticket?

Pine added a comment.Nov 11 2016, 7:03 PM

@Dzahn the filtering problem seems to be resolved now. I have suggested to @TFlanagan-WMF that he update the list of admins. Thanks.

NSaad added a comment.May 4 2017, 5:56 PM

Thank you for adding me to this thread. We are not sure what the problem is. Both Tighe and myself have adjusted the filter settings, and nothing seems to work. Let me know what you need from our end to sort this out.

NSaad added a comment.Jun 12 2017, 7:17 PM

We are still having a problem with emails being rejected to the list. Is there any update on this?

Pine added a comment.Jun 12 2017, 7:35 PM

@NSaad I haven't encountered this problem in awhile. If you, @TFlanagan-WMF and others are comfortable with appointing me as a list admin, I could spend a few minutes looking around around the list's settings. After I'm done with that, you can remove me from the list of admins or keep me -- either is fine, although if I start to get a lot of admin notifications then I may ask to be removed. One way or another, I hope that the underlying problem with the filter rule issue will get fixed.

NSaad added a comment.Jun 12 2017, 7:48 PM

@Pine I've added you as an admin, and I'll email you the password.

Pine added a subscriber: Esh77.EditedJun 12 2017, 8:35 PM

@NSaad Thanks. I looked around the list settings and I don't see anything wrong. Additionally, the list is set to move emails that are filtered into the moderation queue instead of deleting them. If you're OK with leaving me as a list admin for the foreseeable future, I'd like to see what happens when an email goes to the list that gets blocked by a filter rule. The email should go to moderation, and while it's there I'd like to look at it to see if I can figure out what's causing the filter to trigger. Is that OK with you? Also pinging the other list admins @TFlanagan-WMF and @Esh77 to make sure that everyone agrees and knows what to expect. For emphasis: when emails get filtered and go to the moderation queue, please don't delete them or approve them before I look at them, because I want to look at them to try to figure out why messages are being filtered that shouldn't be filtered. Thanks!

NSaad added a comment.Jun 12 2017, 8:59 PM

@Pine Thanks for taking a look, and it is fine with me if you stay on to see what the problem is. There is one specific email that keeps getting bounced. I can forward it to you as well.

Pine added a comment.Jun 12 2017, 10:51 PM

I think that I've narrowed down the problem to 2 of the spam filters. I have left those set to moderation and the others to discard. You may start to see some spam held for moderation, but hopefully good posts will be moderated instead of rejected by whichever spam filter has been causing good emails to get rejected.

I tweaked one of the filters where I noticed some syntax that didn't make sense to me. It may have been irrelevant, or it may be the root of the problem; I can't tell without doing more testing.

I suggest leaving the filter settings as I have them for the time being. If more good emails get rejected or held for moderation, or if a lot of junk accumulates in the moderation queue, you can make adjustments.

You can now remove me from the admin list, or keep me; either is fine.

Pine closed this task as Resolved.Jun 12 2017, 10:56 PM
Pine claimed this task.

I'm marking this Phab task as resolved for now. Feel free to re-open if necessary.

Pine added a comment.Jun 14 2017, 3:50 AM

You're welcome. :)

Since no one has removed me from the list admins group, I'm going to take the liberty of trying to reduce the volume of email that's being held for moderation. This might cause a legitimate email to get dumped, but if that happens and you hear about it, setting the spam filters back to moderation instead of rejection is easy to do temporarily until the legitimate email is resent and caught in the moderation queue, from which the legitimate email can be forwarded to the list. If you need pointers in how to change the filter settings, I can probably do this in 5 minutes and would be happy to set up a quick meeting.